/*auto readmore*/ /*auto readmore*/ /* an hien script*/ // an hien password /*an hien ma chuong trinh cong tru */ /*Scrollbox thanh cuon*/ /***Nhung CODE***/ /* dòng xanh dòng trắng */ /* https://cdnjs.com/libraries/prism lay thu vien, can vao ten file ma goi 1. copy link vao vi du:prism-python.min.js 2. ten ngon nua la python */ /*=== New posts ===*/ /*header slider*/ /*=== bai viet lien quan===*/ /*===tabcode===*/

Juniper - Clearing IDLE TTY Sessions in Junos



Khi có nhiều kết nối đồng thời đến thiết bị bạn có thể ngắt kết nối của user mà bạn muốn.

Hiển thị các session hiện tại đang kết nối trên switch bằng lệnh:
run show system users no-resolve




chúng ta có thể clear TTY sesion, ví dụ clear TTY có tên là u0 thi thực hiện bằng lệnh:

run request system logout terminal u0


Kiểm tra lại thì không session u0 đã được ngắt kết nối.


AWK Command In Linux/Ubuntu/CentOS

Command Giải Thích Kết Quả
echo "Linux commands" | awk '{$2="DONG LENH";print $0}' Thay đổi nội dung của cột thứ 2 của chuỗi "Linux command" trong lệnh echo thành "DONG LENH" và in toàn bộ nội của chuỗi sau khi thay đổi Linux DONG LENH
echo 'foo:123:bar:456' | awk -F: '{print $2}' In ra cột thứ 2 trong chuổi 'foo:123:bar:456' (F: có nghĩa căn cứ vào dấu ":" để tách cột). 123
echo 'foo:123:bar:456' | awk -F: '{print $NF}' In ra cột cuối cùng 456
echo 'foo:123:bar:456' | awk -F: '{print $(NF-1)}' IN ra cột trước cột cuối cùng 1 cột bar
awk '{print}' file.txt In toàn bộ nội dung của file.txt
awk '{print $2}' file.txt In ra nội dung của cột thứ 2 trong file.txt
awk -F: '{print $1}' /etc/passwd In ra nội dung của cột thứ nhất trong file passwd
awk '$2 > 300' file.txt In ra nội dung của dòng đó nếu giá trị của cột thứ 2 > 300
awk '{if($2 > 300) print $0 }' file.txt In ra cả dòng nếu giá trị của cột thứ 2 lớn hơn 300
awk '{if($2 > 300) print $2 }' file.txt In ra giá trị của cột thứ 2 nếu giá trị đó lớn hơn 300

Xong!

Sed Command in Linux/Ubuntu/CentOS - Tìm Kiếm & Thay Thế

Mục Lục

1. Cài đặt Sed

2. Ví dụ


Nội Dung:

1. Cài đặt Sed

sudo apt-get install sed

Kiểm tra version sau khi cài đặt

sed --version


2. Ví dụ

Command Giải Thích
sed 1s/thu/THU/g file.txt Tìm chữ "thu" ở dòng thứ 1 của file có tên file.txt, thay thế bằng chữ "THU" và hiển thị nội dung ra của file và thông tin vừa thay đổi ra màn hình
sed 1,5s/thu/THU/g file.txt Tìm chữ "thu" ở dòng thứ 1 đến dòng thứ 5 của file có tên file.txt và thay thế bằng chữ "THU" và hiển thị nội dung ra của file ra màn hình
sed -i 1,5s/thu/THU/g file.txt Tìm chữ "thu" ở dòng thứ 1 đến dòng thứ 5 của file có tên file.txt và thay thế bằng chữ "THU" và lưu file, KHÔNG hiển thị nội dung ra của file ra màn hình
sed -i 1,5s/thu/THU/gc file.txt Hiển thị thông tin yêu cầu xác nhận trước thực hiện thay thế
sed -i '2i NoiDung' file.txt Chèn chữ "NoiDung" vào dòng thứ 2 của file.txt
sed 6,9s/thu/THU/g file.txt >filecp.txt Tìm chữ "thu" ở dòng thứ 6 đến dòng thứ 9 của file.txt, thay thế bằng chữ "THU" và lưu nội dung file và kết quả vừa thay thế vào filecp.txt
sed -n "/THU/p" filecp.txt Hiển thị tất cả các dòng có chứa chữ "THU" trong filecp.txt
sed -n "/1/ s/10/MUOI/p" filecp.txt Tìm trong filecp.txt nếu có "1" và tìm tiếp nếu có "10" thì thay thế bằng "MUOI", và hiển thị ra màn hình của dòng sau khi thay thế
sed -n "2p; 5p" filecp.txt Hiển thị dòng thứ 2 và dòng thứ 5 của filecp.txt
sed "2 s/hai/HAI/" filecp.txt Nếu dòng thứ 2 của filecp.txt có "hai" thì thay bằng "HAI" và hiển thị ra. Nếu không có thì hiển thị nội dung hiện tại
sed -i "s/10/MUOI/" file.txt filecp.txt Tìm "10" trong file.txt và filecp.txt nếu có thì thay bằng "MUOI" và lưu lại
sed "/12/Id" filecp.txt Tìm kiếm trong filecp.txt nếu có "12" thì xóa dòng đó, sau đó hiển thị kết quả sau khi xóa ra màn hình

Xong!

Security Fundamentals In Linux/Ubuntu/CentOS

 

Command Giải Thích
su itsupport Switch user sang user itsupport, vẫn đứng tại thư mục hiện tại
su - itsupport Switch user sang user itsupport, thiết lập các biến môi trường giống như account itsupport login vào hệ thống
exit Sau khi switch muốn trở lại user trước đó gõ exit
sudo super user do, là user root
sudo su Switch to user root
sudo -k Mặt định timestamp_timeout=30 có nghĩa là trong vòng 30 giây nếu thực hiện lênh sudo sẽ không yêu cầu nhập password, nếu muốn không hỏi password nữa chỉnh lại thời gian là timeout=0. Khi gõ sudo -k có nghĩa timeout ngay lập tức.

JUNIPER - JUNOS Cấu Hình Căn Bản

Dưới đây chúng tôi liệt kê các lệnh cơ bản nhất khi cấu hình dòng sản phẩm EX Series Ethernet Switches chạy trên JunOS để giúp cho các bạn làm quen với Juniper Networks

NỘI DUNG:

1. Cấu hinh căn bản Juniper Networks

2. Tạo vlan Juniper Networks

3. Đặt IP Address/Configure Interface or Vlan IP Address Juniper Networks

4. Interface-mode (Access/Trunking) Juniper EX Series

5. Configuring Static Route Preferences/Default Route Juniper Networks

6. DHCP Server Configuration Juniper Networks

7. DHCP Relay Agent Configuration Juniper Networks

8. Configure Power over Ethernet (PoE) interfaces on EX-series Switches

9. Configuring An Interface Range on EX-series Switches

10. Voice Data on Single Access Port (Supported LLDP-MED)

11. Tổng hợp cấu hình - Quit Configuration


THỰC HIỆN

1. Cấu hinh căn bản Juniper Networks

Commands Diễn Giải
cli vào mode cli
set date 202104151020.30 Thiết lập thời gian là: 10 giờ 20 phút 30 giây ngày 15 tháng 04 năm 2021 (định dạng là: YYYYMMDDHHMM.ss)
configure vào mode config để bắt đầu cấu hình
set system host-name R1-EX3400-24P Đặt tên cho thiết bị là R1-EX3400-24P
set system login message "===Đây là Switch R1-EX3400-24P===" Khi truy cập vào thiết bị sẽ hiển thị banner có nội dung là: "===Đây là Switch R1-EX3400-24P==="
set system domain-name 8.8.8.8 Đặt DNS mặc định có IP là: 8.8.8.8
set system time-zone GMT+7 Đặt múi giờ là GMT+7
set system root-authentication plain-text-password Đặt password cho user root(sau khi enter sẽ nhập password đặt enter để xác nhận lại password)
set system login user admin class super-user authentication plain-text-password Tạo user admin đặt password cho user admin(sau khi enter sẽ nhập password đặt enter để xác nhận lại password)
set system service telnet Cài đặt service telnet
set system service SSH Cài đặt service SSH
set system services web-management https system-generated-certificate Cài đặt service web và sử dụng https
commit check kiểm tra thông tin cấu hình trước khi lưu
commit lưu cấu hình
show | compare So sánh/kiểm tra cấu hình đã thay đổi thế nào


2. Tạo vlan Juniper Networks

Commands Diễn Giải
set vlans vlan-10 vlan-id 10 Tạo vlan có tên là vlan-10 và id của vlan là 10
set vlans vlan-10 description "==Used for MainOffice==" vlan-10 có phần chú thích là "==Used for MainOffice=="
show vlans Hiển thị các vlan đã được tạo trên switch


3. Đặt IP Address/Configure Interface or Vlan IP Address Juniper Networks

3.1 Đặt IP address trên interface

Commands Diễn Giải
set interfaces ge-0/0/10 unit 0 family inet address 10.10.10.254/24 Gán interface ge-0/0/10 có địa chỉ IP là 10.10.10.254/24
set interfaces ge-0/0/10 unit 0 description "==Dat IP cho interface==" Interface ge-0/0/10 có phần chú thích là "==Dat IP cho interface=="
show interfaces ge-0/0/10 Xem các thông tin đã được cấu hình trên interface ge-0/0/10
run show interfaces terse Hiển thị thông tin trạng thái của tất cả interface trong Juniper (tương đương lệnh show ip interface brief trong cisco )
run show interfaces ge-0/0/10 terse Hiển thị thông tin trạng thái up/down, hiển thị thông tin IP được cấu hình trên interface ge-0/0/10

3.2 Đặt IP address trên interface vlan

Commands Diễn Giải
set vlans vlan-11 vlan-id 11 Tạo vlan có tên là vlan-11 và id của vlan là 11
set interfaces irb unit 11 family inet address 11.11.11.254/24

HOẶC

set interfaces irb.11 family inet address 11.11.11.254/24
Interface irb.11 (trong Juniper interface irb dùng cho interface vlan) có địa chỉ IP address là 11.11.11.254/24


vì irb unit 11 có thể viết là irb.11
set vlans vlan-11 l3-interface irb.11 Gán interface irb.11 vào interface vlan-11, hoặc cũng có thể hiểu là gán IP 11.11.11.254 vào interface vlan-11

3.3 Đặt IP address trên interface me0 Managenment-MGMT

Commands Diễn Giải
set interfaces me0 unit 0 family inet address 192.168.123.254/24 Gán interface me0 (là interface Managenment) có địa chỉ IP là 192.168.123.254/24

Noted: Juniper chỉ chấp nhận việc đặt IP trên subInterface, nên mỗi khi đặt ip chúng ta phải gõ thêm theo cú pháp là tên interface unit <số> hoặc interface.<số>. 
ví dụ
irb unit 11 tương đương irb.11
- ge-0/0/10 unit 0 tương đương ge-0/0/10.0


* Kiểm tra thông tin cấu hình interface vlan 11:

Commands Kết quả

show vlans
vlan-11 {
       vlan-id 11;
       l3-interface irb.11;
}

show interfaces irb
unit 11 {
     family inet {
         address 11.11.11.254/24;
     }
}

4. Interface-mode (Access/Trunking) Juniper EX Series

Commands Giải Thích
set interfaces ge-1/0/11 unit 0 family ethernet-switching interface-mode access Gán interfaces ge-1/0/11 là mode access
set interfaces ge-1/0/11 unit 0 family ethernet-switching vlan members vlan-11 Interfaces ge-1/0/11 thuộc vlan-11
set interfaces ge-1/0/12 unit 0 family ethernet-switching interface-mode trunk Gán interfaces ge-1/0/12 là mode trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching vlan members all Interfaces ge-1/0/12 cho phép tất cả các vlan có trên switch đi qua
run show interfaces ge-1/0/12.0
Kiểm tra trunk trên interface ge-1/0/12.0 nếu có cấu hình thì
Flash: Trunk-Mode 
run show ethernet-switching interface Kiểm tra vlan members trên trunk hay trunk cho phép những vlan nào đi qua

Noted: Một số dòng thiết bị hiểu là port-mode thay cho vì interface-mode

5. Configuring Static Route Preferences/Default Route Juniper Networks

Commands Giải Thích
set routing-options static route 0.0.0.0/0 next-hop 10.10.10.1 default route trỏ về 10.10.10.1
set routing-options static route 0.0.0.0/0 preference 11 Cài đặt độ ưu tiên (AD) là 11
run show route Kiểm tra thông tin routing table

* Kiểm tra thông tin route đã cấu hình

Commands Kết quả

show routing-options
nonstop-routing;
       static {
route 0.0.0.0/0 next-hop 10.10.10.1; }


6. DHCP Server Configuration Juniper Networks

Commands Diễn Giải
set access address-assignment pool dhcp-vlan-11 family inet network 11.11.11.0/24 - Cấu hình pool DHCP có tên là dhcp-vlan-11
- Network cho pool dhcp-vlan-11 là 11.11.11.0/24
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 low 11.11.11.11 Địa chỉ thấp nhất có thể cấp cho cho các DHCP Client là 11.11.11.11
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 high 11.11.11.200 Địa chỉ cao nhất có thể cấp cho cho các DHCP Client là 11.11.11.200
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.8.8 Thiết lập DNS Server thứ nhất cho DHCP Client là 8.8.8.8
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.4.4 Thiết lập DNS Server thứ hai cho DHCP Client là 8.8.4.4
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes router 11.11.11.254 Thiết lập default gateway cho DHCP Client là 11.11.11.254
set system services dhcp-local-server group dhcp-vlan-11 interface irb.11 Nếu có thiết bị trong interface irb.11(vlan-11) xin DHCP thì sẽ sử dụng pool có tên dhcp-vlan-11
show access address-assignment Hiển thị thông tin các pool DHCP hiện có trên switch
show system services dhcp-local-server Hiển thị thông tin các interface/vlan có thể sử dụng DHCP server trên switch

* Kiểm tra thông tin DHCP server

Commands Kết quả

show access address-assignment
pool dhcp-vlan-11 {
      family inet {
             network 11.11.11.0/24;
             range range-vlan-11 {
                  low 11.11.11.11;
                  high 11.11.11.200;
             }
             dhcp-attributes {
                    name-server {
                          8.8.8.8;
                          8.8.4.4;
                   }
                   router {
                             11.11.11.254;
                  }
              }
      }
}

show system services dhcp-local-server
group dhcp-vlan-11 {
        interface irb.11;
}


7. DHCP Relay Agent Configuration Juniper Networks


Commands Diễn Giải
set forwarding-options dhcp-relay server-group DHCP-RELAY 172.16.126.11 172.16.126.11 là địa chỉ IP của DHCP Server (đây là DHCP server không nằm trên switch, phải đảm bảo hệ thống network phải routing đến được server này), chúng ta có thể có nhiều DHCP Server
set forwarding-options dhcp-relay active-server-group DHCP-RELAY Chỉ định/kích hoạt tên của Server/Nhóm server DHCP được phép relay/iphelper
set forwarding-options dhcp-relay group DHCP-RELAY interface irb.96 Nếu các thiết bị (client) trong vlan sử dụng gateway là ip của interface irb.96 khi xin DHCP thì interface irb.96 sẽ chuyển thông tin đến DHCP server và nhận kết quả trả về từ DHCP server sau đó phản hồi lại cho client
show forwarding-options Hiển thị thông tin DHCP relay đang cấu hình trên switch

Noted: Nếu interface irb.97 muốn dùng dhcp relay chúng ta chỉ cấu hình thêm thêm: "set forwarding-options dhcp-relay group DHCP-RELAY interface irb.97" là đủ


8. Configure Power over Ethernet (PoE) interfaces on EX-series Switches

Commands Diễn Giải
set poe interface ge-0/0/0 Bật PoE trên interface ge-0/0/0
set poe interface all Bật PoE trên tất cả các interface
set poe interface all priority high Bật và thiết lập priority ở mức cao
set poe interface all maximum-power 14 Thiết lập maximum-power là 14 wattage, mặc định là của switch 15.4
show poe interface Kiểm tra trạng thái PoE đã cấu hình trên switch


9. Configuring An Interface Range on EX-series Switches


Commands Diễn Giải
set interfaces interface-range range-port-TEST member-range ge-1/0/0 to ge-1/0/10

HOẶC

set interfaces interface-range range-port-TEST member "ge-1/0/[0-10]"

Tạo nhóm có tên range-port-TEST gồm các interface từ ge-1/0/0 đến ge-1/0/10
set interfaces interface-range range-port-TEST unit 0 family ethernet-switching vlan members vlan-11 Gán nhóm interface có tên range-port-TEST thuộc vlan có tên là vlan-11
set interfaces interface-range range-port-TEST disable Disable các port thuộc range có tên range-port-TEST (disable tương đương shutdown trong cisco)
show interfaces interface-range range-port-TEST Hiển thị thông tin đã cấu hình của range interface có tên range-port-TEST (show trong mode config)
Range port tham khảo

10. Voice Data on Single Access Port (Supported LLDP-MED)



Commands Diễn Giải
set protocols lldp interface all Đảm bảo LLDP enable trên interface (ở đây chúng tôi mở trên tất cả các interface)
set protocols lldp-med interface ge-0/0/2 Enable LLDP-MED trên cổng ge-0/0/2 là cổng đấu nối điện thoại - Voice IP
set protocols lldp-med fast-start 6 Thiết lập số gói tin (6 gói) quảng bá LLDP-MED sau khi detect thiết bị
set vlans vlan-125 vlan-id 125 Đảm bảo vlan-125 dùng cho voice tồn tại trên switch
set vlans vlan-119 vlan-id 119 Đảm bảo vlan-119 dùng cho Data tồn tại trên switch
set switch-options voip interface ge-0/0/2 vlan vlan-125 Cấu hình voice vlan cho interface ge-0/0/2
set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access Chuyển ge-0/0/2 là mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members vlan-119 Gán ge-0/0/2 làm member của vlan-119 (là vlan dùng cho Data)

*Kiểm tra cấu hình:

- show lldp: đảm bảo LLDP-MED đã bật trên interface ge-0/0/2

- show vlan: đảm bảo interface ge-0/0/2 thuộc vào 2 vlan và trạng thái đang active (có dấu sao là đang active)


11. Tổng hợp cấu hình - Quit Configuration

1. Cấu Hình Căn Bản
cli
set date 202104151020.30
configure
set system host-name R1-EX3400-24P
set system login message "===Đây là Switch R1-EX3400-24P==="
set system domain-name 8.8.8.8
set system time-zone GMT+7
set system root-authentication plain-text-password
set system login user admin class super-user authentication plain-text-password
# nhập password muốn đặt
# xác nhận lại password
set system service telnet
set system service SSH
set system services web-management https system-generated-certificate
commit
Noted: Khi copy thì copy đến hết dòng số 9 sau đó đặt password mới và xác nhận password, và tiếp tục copy dán các dòng còn lại

2. Tạo Vlan
set vlans vlan-10 vlan-id 10
set vlans vlan-10 description "==Used for MainOffice=="             
show vlans

3.1 Đặt IP Trên Interface
set interfaces ge-0/0/10 unit 0 family inet address 10.10.10.254/24
set interfaces ge-0/0/10 unit 0 description "==Dat IP cho interface=="
show interfaces ge-0/0/10 

3.2 Đặt IP Cho Vlan
set vlans vlan-11 vlan-id 11
set interfaces irb.11 family inet address 11.11.11.254/24
set vlans vlan-11 l3-interface irb.11
3.3 Đặt IP Port MGMT
set interfaces me0 unit 0 family inet address 192.168.123.254/24
4.1 Interface Mode-Access
set interfaces ge-1/0/11 unit 0 family ethernet-switching interface-mode access
set interfaces ge-1/0/11 unit 0 family ethernet-switching vlan members vlan-11        
4.2 Interface Mode-Trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching vlan members all        
5. Static Route/Default Route
set routing-options static route 0.0.0.0/0 next-hop 10.10.10.1
set routing-options static route 0.0.0.0/0 preference 11        
6. DHCP Server
set access address-assignment pool dhcp-vlan-11 family inet network 11.11.11.0/24
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 low 11.11.11.11
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 high 11.11.11.200
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.8.8
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.4.4
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes router 11.11.11.254
set system services dhcp-local-server group dhcp-vlan-11 interface irb.11
7. HDCP Relay Agent
set forwarding-options dhcp-relay server-group DHCP-RELAY 172.16.126.11
set forwarding-options dhcp-relay active-server-group DHCP-RELAY
set forwarding-options dhcp-relay group DHCP-RELAY interface irb.96
8. Configure Power over Ethernet - PoE
set poe interface ge-0/0/0
set poe interface all
set poe interface all priority high
set poe interface all maximum-power 14
9.1 Cấu Hình Range-Port Vào Vlan
set interfaces interface-range range-port-TEST member-range ge-1/0/0 to ge-1/0/10
set interfaces interface-range range-port-TEST unit 0 family ethernet-switching vlan members vlan-11        
show interfaces interface-range range-port-TEST
9.2 Cấu Hình Range-Port Theo Regular Expression + Disable Các Port Trong Range
set interfaces interface-range range-port-TEST member "ge-1/0/[0-10]"
set interfaces interface-range range-port-TEST disable        
10. Voice Data on Single Access Port
set protocols lldp interface all
set protocols lldp-med interface ge-0/0/2
set protocols lldp-med fast-start 6
set vlans vlan-125 vlan-id 125
set vlans vlan-119 vlan-id 119
set switch-options voip interface ge-0/0/2 vlan vlan-125
set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members vlan-119

Link tham khảo từ juniper

Link tham khảo 


Xong!

P/s: để xóa cấu hình của interface dùng delete

ví dụ: 
- Xóa cấu hình của interface ge-0/0/10: delete interface ge-0/0/10 
- Hoặc của range: delete interfaces interface-range range-vlan-TEST member-range ge-0/0/10 to ge-0/0/14



Basic Regular Expression In Linux/Ubuntu/CentOS

Mục Lục

1. Regular Expression Căn Bản

2. Ví dụ:


Nội dung:

1. Regular Expression Căn Bản

Ký Hiệu Giải Thích
. Bất kỳ ký tự nào
+ MỘT hoặc NHIỀU lần xuất hiện TRƯỚC nó
* Không hoặc NHIỀU lần xuất hiện TRƯỚC nó
? Không hoặc MỘT lần xuất hiện TRƯỚC nó
^ Đại diện cho mẫu ĐỨNG ĐẦU một chuỗi
$ Đại diện cho mẫu KẾT THÚC một chuỗi
[] Tập hợp các ký tự/ khớp với bất kỳ ký tự nào nằm trong trong dấu ngoặc này
() Gom nhóm các mẫu lại với nhau
{n} Tìm chính xác ký tự và n lần xuất hiện của ký tự
{n,m} Khớp với ký tự xuất hiện 'n' lần nhưng không quá 'm'
{n,} Chỉ khớp với ký tự khi nó xuất hiện 'n' lần trở lên
\ Đại diện cho một ký tự đặc biệt
\+ Khớp với một hoặc nhiều lần xuất hiện của ký tự trước
\? Khớp 0 hoặc một lần xuất hiện của ký tự trước

2. Ví dụ:

Commands Giải Thích
cat file.txt | grep a Mở file.txt và tìm chữ 'a' trong file.txt sau đó trả về kết quả.
HOẶC grep a file.txt Tìm chữ 'a' trong file.txt, tuy nhiên với cách tìm kiếm này ít tốn tài nguyên hơn
cat file.txt | grep ^a Tìm chuỗi bắt đầu bằng chữ 'a' trong file.txt
cat file.txt | grep g$ Tìm chuỗi kết thúc bằng chữ 'g' trong file.txt
cat file.txt | grep .a Tìm a và bất kỳ ký tự nào đứng trước a
cat file.txt | grep a. Tìm a và bất kỳ ký tự nào đứng sau a
cat file.txt | grep -E p\{2} Trả về 1 chuỗi nếu trong chuỗi có có chữ 'p' xuất hiện 2 lần
grep -v ^$ /etc/login.defs | grep -v ^\# Hiển thị nội dung file login.defs nhưng không hiển thị các dòng trắng và dòng giải thích (bắt đầu bằng dấu #)

Xong!

/*header slide*/