/*auto readmore*/ /*auto readmore*/ /* an hien script*/ // an hien password /*an hien ma chuong trinh cong tru */ /*Scrollbox thanh cuon*/ /***Nhung CODE***/ /* dòng xanh dòng trắng */ /* https://cdnjs.com/libraries/prism lay thu vien, can vao ten file ma goi 1. copy link vao vi du:prism-python.min.js 2. ten ngon nua la python */ /*=== New posts ===*/ /*header slider*/ /*=== bai viet lien quan===*/ /*===tabcode===*/
Showing posts with label OSPF. Show all posts
Showing posts with label OSPF. Show all posts

Network Automation #005 - Netmiko Config Changes - OSPF Multiple Areas

Nên xem các bài dưới đây trước khi xem bài này:


Sơ đồ lab:

                  

Yêu Cầu:

Dùng thư viện Netmiko SSH vào các route để cấu hình OSPF đảm bảo mạng hội tụ (tất cả các IP sơ đồ có thể ping thấy nhau)


Chuẩn bị:

  • Đấu nối interface management: Các interface Et0/0 của tất cả các router nối vào lớp mạng 192.168.0.0/24, lớp mạng này chỉ dùng trong việc quản lý thiết bị, không tham gia vào quá trình định tuyến của các router trong sơ đồ mạng.

  • Cấu hình căn bản: trên các router đảm bảo netmiko: 192.168.0.48 có thể ssh vào được các router


Thực hiện:

  • Chuẩn bị file cấu hình mẫu:
R1.txt
interface e0/2
ip address 192.168.14.1 255.255.255.0
no shutdown
exit
interface e0/3
ip address 192.168.13.1 255.255.255.0
no shutdown
exit
interface e0/1
ip address 192.168.123.1 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.1.1 255.255.255.0
no shutdown
exit
!
router ospf 1
router-id 1.1.1.1
exit
!
int rang e0/1 ,e0/3, lo 0
ip ospf 1 are 0
exit
int rang e0/2
ip ospf 1 are 1
exit
end
wri

R2.txt
interface e0/1
ip address 192.168.123.2 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.2.1 255.255.255.0
no shutdown
exit
!
router ospf 1
router-id 2.2.2.2
exit
!
int rang e0/1 
ip ospf 1 are 0
exit
int lo 0
ip ospf 1 are 2
exit
end
wri
R3.txt
interface e0/3
ip address 192.168.13.3 255.255.255.0
no shutdown
exit
interface e0/1
ip address 192.168.123.3 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.3.1 255.255.255.0
no shutdown
exit
!
router ospf 1
router-id 3.3.3.3
exit
!
int rang e0/1 ,e0/3, lo 0
ip ospf 1 are 0
exit
end
wri

R4.txt
interface e0/2
ip address 192.168.14.4 255.255.255.0
no shutdown
exit
interface Lo0
ip address 8.8.8.8 255.255.255.0
no shutdown
exit
!
router ospf 1
router-id 4.4.4.4
exit
!
int rang e0/2
ip ospf 1 are 1
exit
int lo 0
ip ospf 1 are 1
exit
end
wri

  • Code:
from netmiko import ConnectHandler 
'''
Thực hiện import file cấu hình:
- R1.txt vào R1
- R2.txt vào R2
- R3.txt vào R3
- R4.txt vào R4
'''

ios_device = {} 				# định nghĩa dictionnay rỗng
cfg_device = "R1,R2,R3,R4"		# danh sách các Router cần cấu hình
cfg_device = cfg_device.split(",")

def send_config_file(txt):
	
	print(f"Dang ket noi vao IP:'{values[1]}' voi Username: '{values[2]}'")	

	net_connect = ConnectHandler(**ios_device)			# khởi tạo kết nối đến router
	output = net_connect.send_config_from_file(txt) 	# thực hiện import cấu hình vào router
	print(f"Da import file cau hinh:'{txt}' OSPF vao IP: '{values[1]}' thanh cong!")
	print("-" * 80)
	#print(txt)       
      
with open ("device_listOSPF.csv","r") as rfile: 
	keys = rfile.readline().split(",")
	values = rfile.read()
	x = 0  # khởi tạo biến đếm
	for values in values.splitlines(): 
		values = values.split(",") 
		for i in range(1,len(keys)-1,1): 
			ios_device[keys[i]] = values[i]  
		
		send_config_file(cfg_device[x] + ".txt")
		x += 1


  • Kết quả:
C:\python>python Demo.py
Dang ket noi vao IP:'192.168.0.1' voi Username: 'admin'
Da import file cau hinh:'R1.txt' OSPF vao IP: '192.168.0.1' thanh cong!
--------------------------------------------------------------------------------
Dang ket noi vao IP:'192.168.0.2' voi Username: 'admin'
Da import file cau hinh:'R2.txt' OSPF vao IP: '192.168.0.2' thanh cong!
--------------------------------------------------------------------------------
Dang ket noi vao IP:'192.168.0.3' voi Username: 'admin'
Da import file cau hinh:'R3.txt' OSPF vao IP: '192.168.0.3' thanh cong!
--------------------------------------------------------------------------------
Dang ket noi vao IP:'192.168.0.4' voi Username: 'admin'
Da import file cau hinh:'R4.txt' OSPF vao IP: '192.168.0.4' thanh cong!
--------------------------------------------------------------------------------
[Finished in 32.6s]


Các common thường sử dụng trong phương thức netmiko:

  • net_connect.send_command() - Send command down the channel, return output back (pattern based)
  • net_connect.send_command_timing() - Send command down the channel, return output back (timing based)
  • net_connect.send_config_set() - Send configuration commands to remote device
  • net_connect.send_config_from_file() - Send configuration commands loaded from a file
  • net_connect.save_config() - Save the running-config to the startup-config
  • net_connect.enable() - Enter enable mode
  • net_connect.find_prompt() - Return the current router prompt
  • net_connect.commit() - Execute a commit action on Juniper and IOS-XR
  • net_connect.disconnect() - Close the connection
  • net_connect.write_channel() - Low-level write of the channel
  • net_connect.read_channel() - Low-level write of the channel
Xong!

LAB OSPF Multiple Areas

Sơ đồ lab:



Yêu Cầu:

1. Thực hiện đấu nối dây và đặt ip như sơ đồ

2. Cấu hình OSPF đảm bảo tất cả các IP có thể ping thấy nhau

3. Hiệu chỉnh Router - ID cho các router là:

  • R1: 1.1.1.1
  • R2: 2.2.2.2
  • R3: 3.3.3.3
  • R4: 4.4.4.4

4. Hiệu chỉnh quá trình bình bầu DR/BDR kết nối giữa:

  • R1-R2-R3:  đảm bảo R1 là DR; R2 là BDR
  • R1-R4: đảm bảo R1 luôn là DR

5. Hiệu chỉnh metric để R3 đi đến Loopback0 của R4 hay R3 đến ip 8.8.8.8 phải đi qua cổng E0/3 của R1


Thực Hiện:

1. Thực hiện đấu nối dây và đặt ip như sơ đồ

R1:

enable
conf t
hostname R1
ip domain name OSPF.lab

username admin privilege 15 password admin1234

line vty 0 4
login local
transport input ssh
crypto key generate rsa general-keys modulus 1024
ip ssh version 2

interface e0/2
ip address 192.168.14.1 255.255.255.0
no shutdown
exit
interface e0/3
ip address 192.168.13.1 255.255.255.0
no shutdown
exit
interface e0/1
ip address 192.168.123.1 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.1.1 255.255.255.0
no shutdown
exit
do wri

R2:
enable
conf t
hostname R2
ip domain name OSPF.lab

username admin privilege 15 password admin1234

line vty 0 4
login local
transport input ssh
crypto key generate rsa general-keys modulus 1024
ip ssh version 2

interface e0/1
ip address 192.168.123.2 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.2.1 255.255.255.0
no shutdown
exit
do wri

R3:

enable
conf t
hostname R3
ip domain name OSPF.lab

username admin privilege 15 password admin1234

line vty 0 4
login local
transport input ssh
crypto key generate rsa general-keys modulus 1024
ip ssh version 2

interface e0/3
ip address 192.168.13.3 255.255.255.0
no shutdown
exit
interface e0/1
ip address 192.168.123.3 255.255.255.0
no shutdown
exit
interface Lo0
ip address 172.16.3.1 255.255.255.0
no shutdown
exit
do wri

R4:

enable
conf t
hostname R4
ip domain name OSPF.lab

username admin privilege 15 password admin1234

line vty 0 4
login local
transport input ssh
crypto key generate rsa general-keys modulus 1024
ip ssh version 2

interface e0/2
ip address 192.168.14.4 255.255.255.0
no shutdown
exit
interface Lo0
ip address 8.8.8.8 255.255.255.0
no shutdown
exit
do wri



2. Cấu hình OSPF đảm bảo tất cả các IP có thể ping thấy nhau

R1:

ena
conf t
router ospf 1
exit
!
int rang e0/1 ,e0/3, lo 0
ip ospf 1 are 0
exit
int rang e0/2
ip ospf 1 are 1
exit
end
wri

R2:
ena
conf t
router ospf 1
exit
!
int rang e0/1 
ip ospf 1 are 0
exit
int lo 0
ip ospf 1 are 2
exit
end
wri

R3:
ena
conf t
router ospf 1
exit
!
int rang e0/1 ,e0/3, lo 0
ip ospf 1 are 0
exit
end
wri

R4:
ena
conf t
router ospf 1
exit
!
int rang e0/2
ip ospf 1 are 1
exit
int lo 0
ip ospf 1 are 1
exit
end
wri


Kiểm tra:

  • Bảng neighbor của các router

R1:

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.2.1        1   FULL/BDR        00:00:38    192.168.123.2   Ethernet0/1
172.16.3.1        1   FULL/DR         00:00:39    192.168.123.3   Ethernet0/1
172.16.3.1        1   FULL/DR         00:00:36    192.168.13.3    Ethernet0/3
8.8.8.8           1   FULL/DR         00:00:30    192.168.14.4    Ethernet0/2
R1#
R2:
R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1        1   FULL/DROTHER    00:00:32    192.168.123.1   Ethernet0/1
172.16.3.1        1   FULL/DR         00:00:32    192.168.123.3   Ethernet0/1
R2#
R3:
R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1        1   FULL/DROTHER    00:00:31    192.168.123.1   Ethernet0/1
172.16.2.1        1   FULL/BDR        00:00:30    192.168.123.2   Ethernet0/1
172.16.1.1        1   FULL/BDR        00:00:36    192.168.13.1    Ethernet0/3
R3#
R4:
R4#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1        1   FULL/BDR        00:00:36    192.168.14.1    Ethernet0/2
R4#

Tất cả các router đã thiết lập được quan hệ láng giềng

  • Bảng định tuyến của các router
R1:
R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/32 is subnetted, 1 subnets
O        8.8.8.8 [110/11] via 192.168.14.4, 00:36:36, Ethernet0/2
      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O IA     172.16.2.1/32 [110/11] via 192.168.123.2, 00:35:15, Ethernet0/1
O        172.16.3.1/32 [110/11] via 192.168.123.3, 00:35:15, Ethernet0/1
                       [110/11] via 192.168.13.3, 00:35:15, Ethernet0/3
R1#
R2:
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/32 is subnetted, 1 subnets
O IA     8.8.8.8 [110/21] via 192.168.123.1, 00:35:24, Ethernet0/1
      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O        172.16.1.1/32 [110/11] via 192.168.123.1, 00:35:24, Ethernet0/1
O        172.16.3.1/32 [110/11] via 192.168.123.3, 00:35:34, Ethernet0/1
O     192.168.13.0/24 [110/20] via 192.168.123.3, 00:35:34, Ethernet0/1
                      [110/20] via 192.168.123.1, 00:35:24, Ethernet0/1
O IA  192.168.14.0/24 [110/20] via 192.168.123.1, 00:35:24, Ethernet0/1
R2#
R3:
R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/32 is subnetted, 1 subnets
O IA     8.8.8.8 [110/21] via 192.168.123.1, 00:36:00, Ethernet0/1
                 [110/21] via 192.168.13.1, 00:36:00, Ethernet0/3
      172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O        172.16.1.1/32 [110/11] via 192.168.123.1, 00:36:00, Ethernet0/1
                       [110/11] via 192.168.13.1, 00:36:00, Ethernet0/3
O IA     172.16.2.1/32 [110/11] via 192.168.123.2, 00:36:00, Ethernet0/1
O IA  192.168.14.0/24 [110/20] via 192.168.123.1, 00:36:00, Ethernet0/1
                      [110/20] via 192.168.13.1, 00:36:00, Ethernet0/3
R3#
R4:
R4#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.16.0.0/32 is subnetted, 3 subnets
O IA     172.16.1.1 [110/11] via 192.168.14.1, 00:37:41, Ethernet0/2
O IA     172.16.2.1 [110/21] via 192.168.14.1, 00:36:31, Ethernet0/2
O IA     172.16.3.1 [110/21] via 192.168.14.1, 00:36:31, Ethernet0/2
O IA  192.168.13.0/24 [110/20] via 192.168.14.1, 00:37:41, Ethernet0/2
O IA  192.168.123.0/24 [110/20] via 192.168.14.1, 00:37:41, Ethernet0/2
R4#


Các route đã được học đầy đủ. Các ký hiệu O IA là route học được OSPF của các area khác


3. Hiệu chỉnh Router - ID cho các router là:

  • R1: 1.1.1.1
  • R2: 2.2.2.2
  • R3: 3.3.3.3
  • R4: 4.4.4.4


R1:

ena
conf t
router ospf 1
router-id 1.1.1.1
end
!
wri

R2:

ena
conf t
router ospf 1
router-id 2.2.2.2
end
!
wri


R3:

ena
conf t
router ospf 1
router-id 3.3.3.3
end
!
wri

R4:
ena
conf t
router ospf 1
router-id 4.4.4.4
end
!
wri


Kiểm tra:

Noted: Chúng ta phải thực hiện xóa process của ospf trên các router sau khi hiệu chỉnh router-id bằng lệnh clear ip ospf process

R1, R2, R3, R4:

clear ip ospf process

Reset ALL OSPF processes? [no]: yes

Thực hiện lại lênh show ip ospf neighbor

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:31    192.168.123.2   Ethernet0/1
3.3.3.3           1   FULL/BDR        00:00:33    192.168.123.3   Ethernet0/1
3.3.3.3           1   FULL/DR         00:00:39    192.168.13.3    Ethernet0/3
4.4.4.4           1   FULL/BDR        00:00:31    192.168.14.4    Ethernet0/2
R1#


4. Hiệu chỉnh quá trình bình bầu DR/BDR kết nối giữa:

  • R1-R2-R3:  đảm bảo R1 là DR; R2 là BDR


Kiểm tra trước khi cấu hình:

R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1               1   FULL/DROTHER    00:00:32    192.168.123.1   Ethernet0/1

2.2.2.2               1   FULL/DR         00:00:34    192.168.123.2   Ethernet0/1

1.1.1.1               1   FULL/BDR        00:00:32    192.168.13.1    Ethernet0/3

R3#


Chúng ta thấy hiện tại việc bình bầu chưa đúng với yêu cầu, bây giờ chúng ta tiến hành hiệu chỉnh prority của ospf trên các cổng kết nối trên các router này. 


Hiệu chỉnh xong, NHỚ XÓA process của ospf bằng lệnh: clear ip ospf process và show ip ospf neighbor kiểm tra lại


R1:
interface  Ethernet0/1
ip  ospf  priority  10

R2:
interface  Ethernet0/1
ip  ospf  priority 5

Kiểm tra trên R3:

R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1              10   FULL/DR         00:00:38    192.168.123.1   Ethernet0/1

2.2.2.2              5   FULL/BDR        00:00:37    192.168.123.2   Ethernet0/1

1.1.1.1              1   FULL/BDR        00:00:36    192.168.13.1    Ethernet0/3

R3#


R1-R2-R3: đã đáp ứng yêu cầu đặt ra.


  • R1-R4: đảm bảo R1 luôn là DR

Trong trường hợp này R1 luôn luôn là DR nên chúng ta cấu hình priory trên cổng Et0/2 của R4 = 0 để R4 không tham gia bình bầu DR

R4:
interface  Ethernet0/2
ip  ospf  priority 0

 

R4#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1           1   FULL/DR         00:00:32    192.168.14.1    Ethernet0/2

R4#


Đáp ứng yêu cầu đặt ra

5. Hiệu chỉnh metric để R3 đi đến Loopback0 của R4 hay R3 đến ip 8.8.8.8 phải đi qua cổng E0/3 của R1

Kiểm tra trước khi cấu hình:

R3#show ip route 8.8.8.8

Routing entry for 8.8.8.8/32

  Known via "ospf 1", distance 110, metric 21, type inter area

  Last update from 192.168.123.1 on Ethernet0/1, 00:11:51 ago

  Routing Descriptor Blocks:

    192.168.123.1, from 1.1.1.1, 00:11:51 ago, via Ethernet0/1

      Route metric is 21, traffic share count is 1

  * 192.168.13.1, from 1.1.1.1, 00:11:51 ago, via Ethernet0/3

      Route metric is 21, traffic share count is 1

R3#


Hiện có 2 hướng để đi đến ip 8.8.8.8 là đi ra khỏi cổng E0/1 và E0/3

R3:

interface Ethernet0/1

ip ospf cost 150


Kiểm tra

R3#show ip route 8.8.8.8

Routing entry for 8.8.8.8/32

  Known via "ospf 1", distance 110, metric 21, type inter area

  Last update from 192.168.13.1 on Ethernet0/3, 00:18:01 ago

  Routing Descriptor Blocks:

  * 192.168.13.1, from 1.1.1.1, 00:18:01 ago, via Ethernet0/3

      Route metric is 21, traffic share count is 1

R3#


Bây giờ chỉ còn lại 1 hướng đi là duy nhất, đáp ứng yêu cầu đặt ra.


Xong!

Static Route, Floating Static Routes/Dự Phòng Đường Đi Với Static Route


Sơ đồ Bài Lab:

Mô tả: Thực hiện việc cấu hình đường đi dự phòng với Static Route dựa vào Administrative Distance

Kiến thức sử dụng trong bài: Static Route, Default Route, OSPF

Yêu cầu:
1. Thực hiện đấu nối và cấu hình IP theo sơ đồ

2. Trên R1, thực cấu hình 2 default route, ưu tiên 1: trỏ về R2-IP 192.168.12.2; ưu tiên 2: trỏ về R3-IP 192.168.13.3 với AD =254

3. Chạy OSPF trên cả 3 router đảm bảo mạng hội tụ

4. Trên R1 cấu hình floating static route để dự phòng đường đi đến loopback của R2 và R3 khi OSPF lỗi quảng bá loopback cho router láng giềng

Thực hiện:
1. Thực hiện đấu nối và cấu hình IP theo sơ đồ

R1:
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
no shutdown
exit
!
interface Ethernet0/2
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
!
interface Ethernet0/3
 ip address 192.168.13.1 255.255.255.0
no shutdown
end
write

R2:
interface Ethernet0/2
 ip address 192.168.12.2 255.255.255.0
no shutdown
exit
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
end
write

R3:
interface Ethernet0/3
ip address 192.168.13.3 255.255.255.0
no shutdown
exit
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
end
write

2. Trên R1, thực cấu hình 2 default route, ưu tiên 1: trỏ về R2-IP 192.168.12.2; ưu tiên 2: trỏ về R3-IP 192.168.13.3 với AD =254
R1:
ip route 0.0.0.0 0.0.0.0 192.168.12.2
ip route 0.0.0.0 0.0.0.0 192.168.13.3 254

Kiểm tra:
R1#show ip route
{...}
Gateway of last resort is 192.168.12.2 to network 0.0.0.0
S*    0.0.0.0/0 [1/0] via 192.168.12.2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/0
L        192.168.1.1/32 is directly connected, Ethernet0/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Ethernet0/2
L        192.168.12.1/32 is directly connected, Ethernet0/2
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, Ethernet0/3
L        192.168.13.1/32 is directly connected, Ethernet0/3

Default route đang trỏ về IP 192.168.12.2 của R2 với AD = 1 (khi cấu hình ip route mà không gõ giá trị AD thì mặt định router sẽ cho AD =1). Việc cấu hình có thêm chỉ số AD như vậy gọi là floating static route

Kiểm tra hoạt động của Floating Static route
R1:
debug ip routing

Shutdown cổng Et0/2 trên R1 để kiểm tra
R1:
interface Et0/1
shutdown
*Apr 22 06:49:26.423: is_up: Ethernet0/2 0 state: 6 sub state: 1 line: 1
*Apr 22 06:49:26.423: RT: interface Ethernet0/2 removed from routing table
*Apr 22 06:49:26.423: RT: del 192.168.12.0 via 0.0.0.0, connected metric [0/0]
*Apr 22 06:49:26.423: RT: delete subnet route to 192.168.12.0/24
*Apr 22 06:49:26.423: RT: del 192.168.12.1 via 0.0.0.0, connected metric [0/0]
*Apr 22 06:49:26.423: RT: delete subnet route to 192.168.12.1/32
*Apr 22 06:49:26.424: RT: del 0.0.0.0 via 192.168.12.2, static metric [1/0]
*Apr 22 06:49:26.424: RT: delete network route to 0.0.0.0/0
*Apr 22 06:49:26.424: RT: default path has been cleared
*Apr 22 06:49:26.424: RT: updating static 0.0.0.0/0 (0x0)  :
   via 192.168.13.3   0
*Apr 22 06:49:26.424: RT: add 0.0.0.0/0 via 192.168.13.3, static metric [254/0]
*Apr 22 06:49:26.424: RT: default path is now 0.0.0.0 via 192.168.13.3
{...}

Hướng đi đến R2 đã bị xóa ra khỏi bảng route và R1 sẽ tự động thêm vào bảng route hướng đi của default bây giờ là thông qua R3 - IP 192.168.13.3 với AD = 254

R1#show ip route
{...}
Gateway of last resort is 192.168.13.3 to network 0.0.0.0
S*    0.0.0.0/0 [254/0] via 192.168.13.3
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Ethernet0/0
L        192.168.1.1/32 is directly connected, Ethernet0/0
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, Ethernet0/3
L        192.168.13.1/32 is directly connected, Ethernet0/3

Ping test trên R1:
R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R1 có thể ping thành công được Lo2 của R2

R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)

R1 không thể ping đến được Lo3 của R3 vì mọi route mà R1 không biết mặt định nó sẽ hỏi R2 mà R2 lại không biết đường đi đến địa chỉ 3.3.3.3 nên kết quả trả về U.U.U (nếu trên windows thì chúng ta sẽ gặp thông báo destination host unreachable). Để giải quyết vấn đền này chúng cần chạy 1 giao thức route bất kỳ  trên cả 3 router để quảng bá các loopback cho router láng giềng.

3. Chạy OSPF trên cả 3 router đảm bảo mạng hội tụ.
R1
router ospf 1
exit
interface range Et0/0, Et0/2-3
ip ospf 1 area 0

R2
router ospf 1
exit
interface range Et0/2,lo2
ip ospf 1 area 0

R3
router ospf 1
exit
interface range Et0/3,Lo3
ip ospf 1 area 0

Host> ping 2.2.2.2
84 bytes from 2.2.2.2 icmp_seq=1 ttl=254 time=0.668 ms
84 bytes from 2.2.2.2 icmp_seq=2 ttl=254 time=0.746 ms
84 bytes from 2.2.2.2 icmp_seq=3 ttl=254 time=0.681 ms
84 bytes from 2.2.2.2 icmp_seq=4 ttl=254 time=0.657 ms
84 bytes from 2.2.2.2 icmp_seq=5 ttl=254 time=0.627 ms
Host> ping 3.3.3.3
84 bytes from 3.3.3.3 icmp_seq=1 ttl=254 time=0.586 ms
84 bytes from 3.3.3.3 icmp_seq=2 ttl=254 time=0.507 ms
84 bytes from 3.3.3.3 icmp_seq=3 ttl=254 time=0.497 ms
84 bytes from 3.3.3.3 icmp_seq=4 ttl=254 time=0.519 ms
84 bytes from 3.3.3.3 icmp_seq=5 ttl=254 time=0.559 ms

Host đã ping đến được các loopback của R2, R3.

4. Trên R1 cấu hình floating static route để dự phòng đường đi đến loopback của R2 và R3 khi OSPF lỗi quảng bá loopback cho router láng giềng

Kiểm tra trước khi cấu hình
R1:
R1#show ip route 2.2.2.2
Routing entry for 2.2.2.2/32
  Known via "ospf 1", distance 110, metric 11, type intra area
  Last update from 192.168.12.2 on Ethernet0/2, 00:00:04 ago
  Routing Descriptor Blocks:
  * 192.168.12.2, from 2.2.2.2, 00:00:04 ago, via Ethernet0/2
      Route metric is 11, traffic share count is 1

Ta thấy hiện tại R1 route đến 2.2.2.2 bằng giao thức OSPF với Distance 110.
Vậy để static route backup cho OSPF chúng ta sẽ điều chỉnh AD của static route lớn hơn Distance của OSPF (mặt định là 110)

 R1:
ip route 2.2.2.2 255.255.255.255 192.168.12.2 111

Bật debug trên R1 để xem log quá trình cập nhật bảng route
debug ip routing

R2
int lo2
no ip ospf 1 area 0

Không quảng bá loopback vào OSPF (nhằm mục đích test việc câp nhật bảng routing trên R1)

R1#
*Apr 22 08:10:28.344: RT: del 2.2.2.2 via 192.168.12.2, ospf metric [110/11]
*Apr 22 08:10:28.344: RT: delete subnet route to 2.2.2.2/32
*Apr 22 08:10:28.345: RT: updating static 2.2.2.2/32 (0x0)  :
    via 192.168.12.2   0
*Apr 22 08:10:28.345: RT: add 2.2.2.2/32 via 192.168.12.2, static metric [111/0]

Route 2.2.2.2 học được từ OSPF đã bị xóa và thay vào đó là route đến Lo2 của R2 học được từ static route với AD = 111
R1#show ip route 2.2.2.2
outing entry for 2.2.2.2/32
  Known via "static", distance 111, metric 0
  Routing Descriptor Blocks:
  * 192.168.12.2
      Route metric is 0, traffic share count is 1

Tương tự các bạn tự thực hiện với R3 nhé!

Xong!

LAB Troubleshooting OSPF - Bài 2

Mục tiêu: Hiện tại R1 và R2 chưa thiết lập được neighbor. Chúng ta phải giải quyết vấn đề sao cho khi sử dụng lệnh show ip ospf neighbor thì các router láng giềng phải hiển thị với trạng thái FULL như ví dụ dưới:


Lý do: Vấn đề liên quan đến gửi và nhận gói tin hello trong OSPF. Tham khảo tóm tắt lý thuyết OSPF and Key ở đây


Ticket 1:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
passive-interface Ethernet0/0
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0


Kiểm tra:
R1
R1#show ip ospf neighbor
R1#
R1#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.12.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    No Hellos (Passive interface)
 Supports Link-local Signaling (LLS)
{...}

R2
R2#show ip ospf  neighbor
R2#
R2#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 192.168.12.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
{...}

Nhận xét:
Ta thấy OSPF trên hai router đã được enable, lớp mạng đã quảng bá đúng, tuy nhiên khi show ip ospf interface et0/0 trên R1 thấy có dòng No Hellos (Passive interface). Nếu chúng ta cấu hình passive interface thì network trên interface vẫn quảng bá tuy nhiên sẽ không gửi gói tin hello của OSPF, gói tin hello rất quang trọng trong việc thiết lập neighbor trong OSPF.

R1
R1#show run | section ospf
router ospf 1
 router-id 1.1.1.1
 passive-interface Ethernet0/0
 network 192.168.12.0 0.0.0.255 area 0

Giải pháp:
Phải xóa bỏ passive-interface Ethernet0/0 trong phần cấu hình OSPF của R1

R1
router ospf 1
no passive-interface Ethernet0/0

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:37    192.168.12.2    Ethernet0/0
R2
R2#show  ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:34    192.168.12.1    Ethernet0/0

Ticket 2:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0
exit
ip access-list extended Permit-Rule
 permit tcp any any
 permit udp any any
 permit icmp any any
 exit
interface Ethernet0/0
 ip access-group Permit-Rule in
end
write


Kiểm tra:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2               1   INIT/DROTHER    00:00:38    192.168.12.2    Ethernet0/0

R2
R2#show ip ospf neighbor
R2#

Trạng thái trên R1 là INIT, R2 là không có gì cả

R1
R1#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
{...}
R2
R2#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  {...}

Interface của cả 2 router đều cấu hình đúng.

Nhận xét:
Với trạng thái INIT trên R1 là do R1 không thể nhận được thông tin trao đổi OSPF từ R2, R2 không nhận được bất kỳ thông tin về OSPF từ R1. OSPF sử dụng gói tin hello để trao đổi với nhau và thiết lập quan hệ láng giềng (neighbor), chúng sử dụng địa chỉ multicast 224.0.0.5

R1
R1#ping 224.0.0.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:
Reply to request 0 from 192.168.12.2, 1 ms
R2
R2#ping 224.0.0.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:
Reply to request 0 from 192.168.12.2, 1 ms

Khi ping địa chỉ multicast 224.0.0.5 mà OSPF sử dụng để trao đổi thông tin thông qua gói tin hello thì cả 2 vẫn nhận thông tin phản hồi của nhau.

R1
R1#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/5 ms
R2
R2#ping 192.168.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Tuy nhiên chúng ta có thể ping đến được IP đấu nối của nhau. Vậy vấn đề có thể là liên quan đến traffic của OSPF multicast  giữa 2 router.

R1
R1#show ip interface et0/0 | include access list
  Outgoing access list is not set
  Inbound  access list is not set
R2
R2#show ip interface et0/0 | include access list
  Outgoing access list is not set
  Inbound  access list is Permit-Rule
R2#show access-lists Permit-Rule
Extended IP access list Permit-Rule
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any (27 matches)

Có access-list Permit-Rule đã gán theo chiều in của interface Et0/0 của R2, và access list này chỉ cho phép tcp, udp và icmp mọi traffic còn lại sẽ bị chặn mặt định ở dòng cuối cùng của access list và dòng này bị ẩn chúng ta không thể thấy.

để thấy rỏ hơn chúng ta có thể debug access và xem có phải địa chỉ multicast có bị chặn hay không ta làm:

R2
access-list 101 permit ip 192.168.12.0 0.0.0.255 host 224.0.0.5
exit
debug ip packet 101 detail 

R2
R2#debug ip packet 101 detail
IP packet debugging is on (detailed) for access list 101
R2#
*Feb  6 05:55:06.071: IP: s=192.168.12.1 (Ethernet0/0), d=224.0.0.5, len 80, access denied, proto=89

Giải pháp:
Sửa lại access list Permit-Rule và chèn dòng permit ospf any any lên trên cùng của access list trên R2

R2
ip access-list extended Permit-Rule
5 permit ospf any any
end
write

Access-list sau khi điều chỉnh trên R2
R2#show access-lists Permit-Rule
Extended IP access list Permit-Rule
    5 permit ospf any any (19 matches)
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any (27 matches)

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:35    192.168.12.2    Ethernet0/0
R2
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:36    192.168.12.1    Ethernet0/0

Ticket 3:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
 ip ospf dead-interval 50
 ip ospf hello-interval 11
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0
exit


Kiểm tra:
R1
R1#debug ip ospf hello
OSPF hello debugging is on
R1#
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Rcv hello from 2.2.2.2 area 0 192.168.12.2
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Mismatched hello parameters from 192.168.12.2
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Dead R 50 C 40, Hello R 11 C 10 Mask R 255.255.255.0 C 255.255.255.0

Nhận xét:
Thấy R1 nhận từ R2 là: Hello intervel là 11 và Dead time là 50

Giải pháp:
Có thể vào interface Et0/0 của R2 bỏ cấu hình dead time và hello interval của OSPF đi, lúc này OSPF sẽ dùng thời gian mặt đinh là 10/40, hoặc vào Et0/0 của R1 cấu hình thêm hello/dead timer là 11/50

R1
interface Ethernet0/0
ip ospf dead-interval 50
ip ospf hello-interval 11
end
write

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:35    192.168.12.2    Ethernet0/0
R2
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:36    192.168.12.1    Ethernet0/0

Kết luận: Các câu lệnh sử dụng trong bài này là:
show ip ospf neighbor
show ip interface <interface>
show ip ospf interface <interface>
show run | section ospf
show ip interface <interface> | include access list
debug ip packet <acl-number> detail
show access-lists
debug ip ospf hello

Xong!


LAB Troubleshooting OSPF - Bài 2

Mục tiêu: Hiện tại R1 và R2 chưa thiết lập được neighbor. Chúng ta phải giải quyết vấn đề sao cho khi sử dụng lệnh show ip ospf neighbor thì các router láng giềng phải hiển thị với trạng thái FULL như ví dụ dưới:


Lý do: Vấn đề liên quan đến gửi và nhận gói tin hello trong OSPF. Tham khảo tóm tắt lý thuyết OSPF and Key ở đây


Ticket 1:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
passive-interface Ethernet0/0
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0


Kiểm tra:
R1
R1#show ip ospf neighbor
R1#
R1#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.12.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    No Hellos (Passive interface)
 Supports Link-local Signaling (LLS)
{...}

R2
R2#show ip ospf  neighbor
R2#
R2#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 192.168.12.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
{...}

Nhận xét:
Ta thấy OSPF trên hai router đã được enable, lớp mạng đã quảng bá đúng, tuy nhiên khi show ip ospf interface et0/0 trên R1 thấy có dòng No Hellos (Passive interface). Nếu chúng ta cấu hình passive interface thì network trên interface vẫn quảng bá tuy nhiên sẽ không gửi gói tin hello của OSPF, gói tin hello rất quang trọng trong việc thiết lập neighbor trong OSPF.

R1
R1#show run | section ospf
router ospf 1
 router-id 1.1.1.1
 passive-interface Ethernet0/0
 network 192.168.12.0 0.0.0.255 area 0

Giải pháp:
Phải xóa bỏ passive-interface Ethernet0/0 trong phần cấu hình OSPF của R1

R1
router ospf 1
no passive-interface Ethernet0/0

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:37    192.168.12.2    Ethernet0/0
R2
R2#show  ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:34    192.168.12.1    Ethernet0/0

Ticket 2:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0
exit
ip access-list extended Permit-Rule
 permit tcp any any
 permit udp any any
 permit icmp any any
 exit
interface Ethernet0/0
 ip access-group Permit-Rule in
end
write


Kiểm tra:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2               1   INIT/DROTHER    00:00:38    192.168.12.2    Ethernet0/0

R2
R2#show ip ospf neighbor
R2#

Trạng thái trên R1 là INIT, R2 là không có gì cả

R1
R1#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
{...}
R2
R2#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           10        no          no            Base
  {...}

Interface của cả 2 router đều cấu hình đúng.

Nhận xét:
Với trạng thái INIT trên R1 là do R1 không thể nhận được thông tin trao đổi OSPF từ R2, R2 không nhận được bất kỳ thông tin về OSPF từ R1. OSPF sử dụng gói tin hello để trao đổi với nhau và thiết lập quan hệ láng giềng (neighbor), chúng sử dụng địa chỉ multicast 224.0.0.5

R1
R1#ping 224.0.0.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:
Reply to request 0 from 192.168.12.2, 1 ms
R2
R2#ping 224.0.0.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:
Reply to request 0 from 192.168.12.2, 1 ms

Khi ping địa chỉ multicast 224.0.0.5 mà OSPF sử dụng để trao đổi thông tin thông qua gói tin hello thì cả 2 vẫn nhận thông tin phản hồi của nhau.

R1
R1#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/5 ms
R2
R2#ping 192.168.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Tuy nhiên chúng ta có thể ping đến được IP đấu nối của nhau. Vậy vấn đề có thể là liên quan đến traffic của OSPF multicast  giữa 2 router.

R1
R1#show ip interface et0/0 | include access list
  Outgoing access list is not set
  Inbound  access list is not set
R2
R2#show ip interface et0/0 | include access list
  Outgoing access list is not set
  Inbound  access list is Permit-Rule
R2#show access-lists Permit-Rule
Extended IP access list Permit-Rule
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any (27 matches)

Có access-list Permit-Rule đã gán theo chiều in của interface Et0/0 của R2, và access list này chỉ cho phép tcp, udp và icmp mọi traffic còn lại sẽ bị chặn mặt định ở dòng cuối cùng của access list và dòng này bị ẩn chúng ta không thể thấy.

để thấy rỏ hơn chúng ta có thể debug access và xem có phải địa chỉ multicast có bị chặn hay không ta làm:

R2
access-list 101 permit ip 192.168.12.0 0.0.0.255 host 224.0.0.5
exit
debug ip packet 101 detail 

R2
R2#debug ip packet 101 detail
IP packet debugging is on (detailed) for access list 101
R2#
*Feb  6 05:55:06.071: IP: s=192.168.12.1 (Ethernet0/0), d=224.0.0.5, len 80, access denied, proto=89

Giải pháp:
Sửa lại access list Permit-Rule và chèn dòng permit ospf any any lên trên cùng của access list trên R2

R2
ip access-list extended Permit-Rule
5 permit ospf any any
end
write

Access-list sau khi điều chỉnh trên R2
R2#show access-lists Permit-Rule
Extended IP access list Permit-Rule
    5 permit ospf any any (19 matches)
    10 permit tcp any any
    20 permit udp any any
    30 permit icmp any any (27 matches)

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:35    192.168.12.2    Ethernet0/0
R2
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:36    192.168.12.1    Ethernet0/0

Ticket 3:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.0
 ip ospf dead-interval 50
 ip ospf hello-interval 11
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0
exit


Kiểm tra:
R1
R1#debug ip ospf hello
OSPF hello debugging is on
R1#
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Rcv hello from 2.2.2.2 area 0 192.168.12.2
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Mismatched hello parameters from 192.168.12.2
*Feb  6 06:12:27.942: OSPF-1 HELLO Et0/0: Dead R 50 C 40, Hello R 11 C 10 Mask R 255.255.255.0 C 255.255.255.0

Nhận xét:
Thấy R1 nhận từ R2 là: Hello intervel là 11 và Dead time là 50

Giải pháp:
Có thể vào interface Et0/0 của R2 bỏ cấu hình dead time và hello interval của OSPF đi, lúc này OSPF sẽ dùng thời gian mặt đinh là 10/40, hoặc vào Et0/0 của R1 cấu hình thêm hello/dead timer là 11/50

R1
interface Ethernet0/0
ip ospf dead-interval 50
ip ospf hello-interval 11
end
write

Kết quả:
R1
R1#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/DR         00:00:35    192.168.12.2    Ethernet0/0
R2
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:36    192.168.12.1    Ethernet0/0

Kết luận: Các câu lệnh sử dụng trong bài này là:
show ip ospf neighbor
show ip interface <interface>
show ip ospf interface <interface>
show run | section ospf
show ip interface <interface> | include access list
debug ip packet <acl-number> detail
show access-lists
debug ip ospf hello

Xong!

LAB Troubleshooting OSPF - Bài 1

Mục tiêu: Hiện tại R1 và R2 chưa thiết lập được neighbor. Chúng ta phải giải quyết vấn đề sao cho khi sử dụng lệnh show ip ospf neighbor thì các router láng giềng phải hiển thị với trạng thái FULL như ví dụ dưới:



Lý do: Vấn đề liên quan đến IP đấu nối giữa 2 router (Layer 3) và việc quảng quá network trong OSPF. Tham khảo tóm tắt lý thuyết OSPF and Key ở đây



Ticket 1:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0
end
write

R2
interface Ethernet0/0
description ===Connect to R1 Et0/0===
ip address 192.168.21.2 255.255.255.0
no shutdown
exit
router ospf 1
router-id 2.2.2.2
network 192.168.12.0 0.0.0.255 area 0
end
write


Kiểm tra:
R1
R1#show ip ospf neighbor 
R1#
R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                192.168.12.1    YES manual up                    up     

R2
R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                192.168.21.2    YES manual up                    up     

Nhận xét:
Ta thấy IP trên cổng đấu nối giữa R1 và R2 không cùng lớp mạng, theo sơ đồ thì IP trên cổng Et0/0 của R2 phải là 192.168.12.2

Giải pháp:
R2:
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0

Kết quả:

R2
R2#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:00:39    192.168.12.1    Ethernet0/0
R2#


R1
R1#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:39    192.168.12.2    Ethernet0/0
R1#

Ticket 2:
Cấu hình ban đầu:

R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0
end
write

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.128
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.12.0 0.0.0.255 area 0
end
write


Kiểm tra:
R1:
R1#show ip ospf neighbor 
R1#
R1#show ip interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet address is 192.168.12.1/24
{...}

R2:
R2#show ip ospf neighbor 
R2#
R2#show ip interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet address is 192.168.12.2/25
  Broadcast address is 255.255.255.255
{...}

Nhận xét: 
Ta thấy IP trên cổng đấu nối giữa R1 và R2 không cùng subnet mask, theo sơ đồ thì IP trên cổng Et0/0 của R2 phải là 192.168.12.2/24. Hiện tại IP Et0/0 của R2 192.168.12.2/25

Giải pháp:
R2:
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0

Kết quả:
R2
R2#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:00:39    192.168.12.1    Ethernet0/0
R2#

R1
R1#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:39    192.168.12.2    Ethernet0/0
R1#

Ticket 3:
Cấu hình ban đầu:


R1
interface Ethernet0/0
 description ===Connect to R2 Et0/0===
 ip address 192.168.12.1 255.255.255.0
no shutdown
exit
router ospf 1
 router-id 1.1.1.1
 network 192.168.12.0 0.0.0.255 area 0
end
write

R2
interface Ethernet0/0
 description ===Connect to R1 Et0/0===
 ip address 192.168.12.2 255.255.255.128
no shutdown
exit
router ospf 1
 router-id 2.2.2.2
 network 192.168.21.0 0.0.0.255 area 0
end
write

Kiểm tra:
R1:
R1#show ip ospf neighbor 
R1#
R1#show ip ospf interface et0/0
Ethernet0/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0, Attached via Network Statement
{...}


R2:
R2#show ip ospf neighbor 
R2#
R2#show ip ospf interface et0/0
%OSPF: OSPF not enabled on Ethernet0/0
R2#
R2#show run | section ospf 1
router ospf 1
 router-id 2.2.2.2
 network 192.168.21.0 0.0.0.255 area 0
R2#

Nhận xét: 
OSPF chưa được enable trên interface Et0/0 của R2, sử dụng lệnh show run | section ospf cho thấy network đã quảng quá không đúng yêu cầu đề bài, network cần quảng quá phải là network 192.168.12.0 0.0.0.255 area 0 (với OSPF: IP trên cổng nằm trong network được quảng bá là OSPF sẽ được enable trên interface đó. Trong trường hợp này chúng ta cũng có thể cấu hình network quảng bá là: 192.168.21.0 0.0.255.255 area 0 ).

Giải pháp:
R2:
router ospf 1
 no network 192.168.21.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0

Kết quả:
R2
R2#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:00:39    192.168.12.1    Ethernet0/0
R2#

R1
R1#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:39    192.168.12.2    Ethernet0/0
R1#

Kết luận: Các câu lệnh sử dụng trong bài này là:
show ip ospf neighbor
show ip interface <interface>
show ip ospf interface <interface>
show run | section ospf 1


Xong!

/*header slide*/