/*auto readmore*/ /*auto readmore*/ /* an hien script*/ // an hien password /*an hien ma chuong trinh cong tru */ /*Scrollbox thanh cuon*/ /***Nhung CODE***/ /* dòng xanh dòng trắng */ /* https://cdnjs.com/libraries/prism lay thu vien, can vao ten file ma goi 1. copy link vao vi du:prism-python.min.js 2. ten ngon nua la python */ /*=== New posts ===*/ /*header slider*/ /*=== bai viet lien quan===*/ /*===tabcode===*/
Showing posts with label Juniper. Show all posts
Showing posts with label Juniper. Show all posts

Network Automation #008 - Netmiko Finding Device IP Addresses Connected To Juniper - JunOS Switch

Nên tham khảo bài Juniper - JunOS (mục 2) trước khi xem bài này

YÊU CẦU: 

Dùng thư viện Netmiko trong python để SSH vào switch Juniper - JunOS để  tìm các thiết bị hiện tại đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó. Các địa chỉ IP cần tìm được lưu trữ trong file "device_list.csv". 

Kết quả tìm được in ra màn hình và lưu vào file "Show_arp_Ketqua_192.168.0.1.csv"

THỰC HIỆN:

1. Chuẩn bị file danh sách thiết bị có dạng


2. Code

'''
Tìm thiết bị đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó
Danh sách các IP cần tìm để trong file "device_list.csv"
(Điều kiện là thiết bị Juniper cần kết nối đã được cấu hình SSH)
Kết quả tìm được in ra màn hình và lưu vào file "Show_arp_Ketqua_192.168.0.1.csv"

Câu lệnh chính dùng trong bài:
- show arp hostname < địa chỉ ip cần tìm>
- show ethernet-switching table <địa chỉ mac cần tìm>

'''
import netmiko # import thư viện netmiko
import os 

# Thông tin thiết bị cần SSH vào (định nghĩa dictionnary)
Sw_1 = { 
	"host":"192.168.0.1",
	"username":"admin",
	"password":"admin1234@core",
	"device_type":"juniper_junos"
	}
print("Connecting to a host: " + Sw_1["host"] + "...") # Hiển thị thông báo kết nối tới
# dùng hàm ConnectHandler trong thư viện netmiko để kết nối với Sw_1 với các thông tin đã định nghĩa trong dictionnary
net_connect = netmiko.ConnectHandler(**Sw_1) 
print("Connected successfully\n")


with open ("device_list.csv","r") as rfile: # mở file

	keys = rfile.readline() # lấy dòng đầu tiên
	values = rfile.read() # các dòng còn lại là giá trị cần gán vào dict

# print(keys)
# print(values)
'''
để remove xuống dòng (newline) chúng ta có thể dùng
print(keys,end="")
'''
file_ketqua = "Show_arp_Ketqua_" + Sw_1["host"] + ".csv" # định nghĩa tên file cần ghi kết quả
file_header = keys.rstrip() + ",Vlan,Mac Address,MAC Flags,Logical Interface\n" # bỏ newline (\n) ở cuối dòng và nối thêm chuỗi để ghi vào file chuẩn bị để chứa kết quả show mac address và chèn newline vào cuối

f = open(file_ketqua,"w") 
# print(file_header)
f.write(file_header)
f.flush() # thực hiện ghi
f.close() # đóng file để giải phóng bộ nhớ

print ("*" * 20 + "KET QUA" + "*" * 20)
for values in values.splitlines(): # trả về một chuỗi tương ứng là một dòng trong biến values
	values = values.split(",") # mỗi dòng chuyển thành list
	ip_addr = values[0] # giá trị của cột đầu tiên là địa chỉ IP cần lấy ra
	ip_description = values[1]
	# print(ip_addr)
	# print(ip_description)
	# print(values)
	print("*" + ip_addr + ":") # In ra IP đang cần show

	net_connect.send_command("ping" + " " + ip_addr + " " + "count 4") # ping (ping 4 gói) địa chỉ IP cần kiểm tra để switch cập nhật vào bảng MAC 
	show_arp = "show arp" + " " + "hostname" + " " + ip_addr
	show_arp = net_connect.send_command(show_arp) # thực hiện lênh show arp với chính IP cần tìm

	#print (show_arp)
	# In ra dòng thứ nhì trong chuỗi
	# print (show_arp.splitlines()[1])

	# lấy dòng thứ nhì và phân ra từng cụm
	fields = show_arp.splitlines()[1].split()

	# lấy cụm đầu tiên (là địa chỉ MAC) tính từ trái sang
	mac_addr = fields[0]

	# print (mac_addr)

	show_mac_addr = "show ethernet-switching table" + " " + mac_addr
	show_mac_addr = net_connect.send_command(show_mac_addr) # thực hiện lệnh show
	print(show_mac_addr)
	show_mac_addr = show_mac_addr.splitlines()[8].split() # lấy dòng thứ 8 chuyển thành list
	#print(show_mac_addr) # In kết quả show ra màn hình
	print() # In ra dòng trắng 
	#print(type(show_mac_addr))
	#print(type(values))
	
	for i in [6,5,3]:  
		del show_mac_addr[i] # thực hiện xóa các phần tử không cần lấy

	show_mac_addr = values + show_mac_addr # thực hiện nối thông tin ban đầu và kết quả 
	
	#print(show_mac_addr)
	show_mac_addr = ",".join(show_mac_addr) + "\n" # convert list sang string và thêm "," vào giữa mỗi cụm
	f = open(file_ketqua,"a") 
	f.write(show_mac_addr) # thực hiện ghi thêm kết quả vào file kết quả
path = os.getcwd() # lấy đường dẫn hiện tại

print("*" * 20 + "KẾT QUẢ ĐƯỢC LƯU TẠI" + "*" * 20)
print(r"{}".format(path))
print(file_ketqua)
print("*" * 60 + "\n")

3. Kết quả:

Connecting to a host: 192.168.0.1...
Connected successfully

********************KET QUA********************
*172.16.125.11:
MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 109 entries, 109 learned
Routing instance : default-switch
    Vlan                MAC                 MAC         Age    Logical                NH        RTR 
    name                address             flags              interface              Index     ID
    vlan-125            c0:74:ad:32:2d:3c   D             -   ge-1/0/1.0             0         0       


*172.16.126.11:
MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 109 entries, 109 learned
Routing instance : default-switch
    Vlan                MAC                 MAC         Age    Logical                NH        RTR 
    name                address             flags              interface              Index     ID
    vlan-126            d4:f5:ef:09:c0:1e   D             -   ge-1/0/3.0             0         0       


********************KẾT QUẢ ĐƯỢC LƯU TẠI********************
C:\vck\LAB
Show_arp_Ketqua_192.168.0.1.csv
************************************************************

[Finished in 17.5s]

Nội dung của file Show_arp_Ketqua_192.168.0.1.csv có dạng


Xong!

Juniper - Backup and Restore Configuration on EX Switches

 NỘI DUNG:

1. Backup Kết Hợp Show Và Log Session Của SecureCRT

2. Restore - Load File

3. Restore - Load Terminal


THỰC HIỆN:

1. Backup Kết Hợp Show Và Log Session Của SecureCRT

- Kết nối đến thiết bị cần backup bằng SecureCRT

- Trên SecureCRT vào File -> LogSession -> Save để lưu các nội dung show vào file này.


- show | no-more

HOẶC

- show | no-more | display set


Sau khi thực hiện lệnh show này toàn bộ nội dung cấu hình sẽ lưu trong file 2021-04-28-Juniper.log


2. Restore - Load File

Commands Diễn Giải
configure Vào mode config
load merge /var/home/admin/2021-04-27_IP127.246.cfg Load file 2021-04-27_IP127.246.cfg nối vào cấu hình hiện tại

3. Restore - Load Terminal

Commands Diễn Giải
configure Vào mode config
load merge terminal sau khi gõ dòng này xong chúng ta dán nội dung cần cấu hình vào
[Type ^D at a new line to end input] sau khi DÁN NỘI DUNG xong nhấn enter để xuống hàng sau đó nhấn Ctrl + D để thực hiện nối nội dung vào cấu hình

xong!

Network Automation #006 - Netmiko How To Find Which Switch Port A Device Is Plugged Into Base on IP Address

Nên đọc bài  LAB #001 trước khi xem bài này

Sơ đồ Lab:


Yêu cầu:  Dùng Netmiko để SSH vào switch sau đó tìm thiết bị có IP 192.168.0.101 đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó:
1. Thực hiện trên Cisco - IOS
2. Thực hiện trên Juniper - JunOS

Thực hiện:
1. Thực hiện trên Cisco - IOS

  • Chuẩn bị (cấu hình trên Cisco switch ):

  • Code:
'''
Tìm thiết bị đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó (Điều kiện là thiết bị cisco cần kết nối đã được cấu hình SSH) Câu lệnh chính dùng trong bài: - show arp <ip cần tìm> - show mac address-table address <địa chỉ mac cần tìm> ''' import netmiko # import thư viện netmiko # Thông tin thiết bị cần SSH vào (định nghĩa dictionnary) Sw_1 = { "host":"192.168.0.1", "username":"admin", "password":"admin1234@core", "device_type":"cisco_ios" } print("Connecting to a host: " + Sw_1["host"] + "...\n") # Hiển thị thông báo kết nối tới # dùng hàm ConnectHandler trong thư viện netmiko để kết nối với Sw_1 với các thông tin đã định nghĩa trong dictionnary net_connect = netmiko.ConnectHandler(**Sw_1) ip_addr = "192.168.0.101" # địa chỉ ip cần tìm net_connect.send_command("ping" + " " + ip_addr) # ping địa chỉ IP cần kiểm tra để switch cập nhật vào bảng MAC show_arp = "show arp" + " " + ip_addr show_arp = net_connect.send_command(show_arp) # thực hiện lênh show arp với chính IP cần tìm # In ra dòng thứ nhì trong chuỗi # print (show_arp.splitlines()[1]) # lấy dòng thứ nhì và phân ra từng cụm fields = show_arp.splitlines()[1].split() # lấy cụm thứ 4 (là địa chỉ MAC) tính từ trái sang, sau đó sẽ thực hiện lệnh show mac với MAC này mac_addr = fields[3] # print (mac_addr) show_mac_addr = "show mac address-table address" + " " + mac_addr show_mac_addr = net_connect.send_command(show_mac_addr) # thực hiện lệnh show print ("*" * 20 + "KET QUA" + "*" * 20) print(show_mac_addr)

  • Kết quả:

Connecting to a host: 192.168.0.1...

********************KET QUA********************
Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
   1    0050.7966.6807    DYNAMIC     Et0/0
Total Mac Addresses for this criterion: 1
[Finished in 8.8s]

Kết quả cho chúng ta thấy IP 192.168.0.101 được kết nối vào port Et0/0 của switch 192.168.0.1

2. Thực hiện trên Juniper - JunOS
  • Chuẩn bị (cấu hình trên Juniper switch ):
Tham khảo cấu hình Juniper tại link 

Noted: Lab Juniper mình làm trên thiết bị thật, nên port sẽ không giống như hình ở trên
  • Code:
''' Tìm thiết bị đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó (Điều kiện là thiết bị Juniper cần kết nối đã được cấu hình SSH) Câu lệnh chính dùng trong bài: - show arp hostname <ip cần tìm> - show ethernet-switching table <địa chỉ mac cần tìm> ''' import netmiko # import thư viện netmiko # Thông tin thiết bị cần SSH vào (định nghĩa dictionnary) Sw_1 = { "host":"192.168.0.1", "username":"admin", "password":"admin1234@core", "device_type":"juniper_junos" } print("Connecting to a host: " + Sw_1["host"] + "...\n") # Hiển thị thông báo kết nối tới # dùng hàm ConnectHandler trong thư viện netmiko để kết nối với Sw_1 với các thông tin đã định nghĩa trong dictionnary net_connect = netmiko.ConnectHandler(**Sw_1) ip_addr = "192.168.0.101" # địa chỉ ip cần tìm net_connect.send_command("ping" + " " + ip_addr + " " + "count 4") # ping (ping 4 gói) địa chỉ IP cần kiểm tra để switch cập nhật vào bảng MAC show_arp = "show arp" + " " + "hostname" + " " + ip_addr show_arp = net_connect.send_command(show_arp) # thực hiện lênh show arp với chính IP cần tìm # print (show_arp) # In ra dòng thứ nhì trong chuỗi # print (show_arp.splitlines()[1]) # lấy dòng thứ nhì và phân ra từng cụm fields = show_arp.splitlines()[1].split() # lấy cụm đầu tiên (là địa chỉ MAC) tính từ trái sang mac_addr = fields[0] # print (mac_addr) show_mac_addr = "show ethernet-switching table" + " " + mac_addr show_mac_addr = net_connect.send_command(show_mac_addr) # thực hiện lệnh show print ("*" * 20 + "KET QUA" + "*" * 20) print(show_mac_addr)

  • Kết quả:

Connecting to a host: 192.168.0.1...

********************KET QUA********************
MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)

Ethernet switching table : 87 entries, 87 learned
Routing instance : default-switch
    Vlan                MAC                 MAC         Age    Logical                NH        RTR 
    name                address             flags              interface              Index     ID
    vlan-11                  d4:f5:ef:09:c0:1e   D             -   ge-1/0/0.0             0         0       

[Finished in 13.1s]

Thiết bị có IP 192.168.0.101 được nối vào port ge-1/0/0 của switch 192.168.0.1
 

Xong!

Juniper - Save And Transfer File Configuration With TFTP

Nên tham khảo bài TFTP trước khi xem bài này


NỘI DUNG:

1. Lưu Cấu Hình Hiện Tại Thành File Lên Switch

2. Copy File Config Từ Switch Đến TFTP

3. Copy File Từ TFTP Vào Switch

4. Backup Cấu Hình Tự Động


THỰC HIỆN:


1. Lưu Cấu Hình Hiện Tại Thành File Lên Switch

Commands Diễn Giải
configure Vào mode config
save 2021-04-27_IP127.246.cfg Thực hiện lưu cấu hình hiện tại vào file có tên 2021-04-27_IP127.246.cfg
exit Thoát khỏi mode config
file list Liệt kê/xem các file cấu hình mà mình tự lưu đã lưu trong thiết bị


2. Copy File Config Từ Switch Đến TFTP

Commands Diễn Giải
start shell Khởi động shell trên Junos
cd /var/home/admin Chuyển dấu nhắc lệnh vào đường dẫn /var/home/admin
ls Liệt kê (nhằm mục đích chọn file để copy) các file có trong đường dẫn /var/home/admin
tftp Khởi động tftp client trên switch
connect 125.234.103.242 Kết nối đến TFTP server có địa chỉ IP là 125.234.103.242
put 2021-04-27_IP127.246.cfg Đẩy file 2021-04-27_IP127.246.cfg (là file vừa tạo ra ở phần 1) lên TFTP server
^D% Nhấn phím Ctrl + D để disconnect khỏi TFTP server
exit Thoát chế độ shell trên switch


Chúng ta cũng có thể copy các file cấu hình hiện tại trên switch lên TFTP

Commands/File List Diễn Giải
file list /config/ Hiển thị các file config của switch
juniper.conf.gz Là file cấu hình đang active trên switch
juniper.conf.1.gz Nếu chúng ta rollback thì nội dung của file juniper.conf.gz sẽ được thay bằng nội dung của file juniper.conf.1.gz


3. Copy File Từ TFTP Vào Switch

Commands Diễn Giải
start shell Khởi động shell trên Junos
tftp 125.234.103.242 Kết nối vào tftp có địa chỉ ip tftp 125.234.103.242
get 2021-04-27_IP127.246.cfg.txt Copy file 2021-04-27_IP127.246.cfg.txt từ TFTP về switch
quit Disconnect khỏi TFTP server
exit Thoát chế độ shell trên switch



4. Backup Cấu Hình Tự Động

Juniper cho phép sao lưu cấu hình tự động thông qua FTP, HTTP, SCP sau mỗi lần chúng ta lưu cấu hình (commit). Tên file tạo ra theo định dạng là hostname+time

    system {

              archival {

                  configuration {

                          transfer-on-commit;

                          archive-sites {

                                  "ftp://username@<IP address of FTP server>" password <password>;

                                  }

                          }

               }

     }


Xong!

Juniper - Clearing IDLE TTY Sessions in Junos



Khi có nhiều kết nối đồng thời đến thiết bị bạn có thể ngắt kết nối của user mà bạn muốn.

Hiển thị các session hiện tại đang kết nối trên switch bằng lệnh:
run show system users no-resolve




chúng ta có thể clear TTY sesion, ví dụ clear TTY có tên là u0 thi thực hiện bằng lệnh:

run request system logout terminal u0


Kiểm tra lại thì không session u0 đã được ngắt kết nối.


JUNIPER - JUNOS Cấu Hình Căn Bản

Dưới đây chúng tôi liệt kê các lệnh cơ bản nhất khi cấu hình dòng sản phẩm EX Series Ethernet Switches chạy trên JunOS để giúp cho các bạn làm quen với Juniper Networks

NỘI DUNG:

1. Cấu hinh căn bản Juniper Networks

2. Tạo vlan Juniper Networks

3. Đặt IP Address/Configure Interface or Vlan IP Address Juniper Networks

4. Interface-mode (Access/Trunking) Juniper EX Series

5. Configuring Static Route Preferences/Default Route Juniper Networks

6. DHCP Server Configuration Juniper Networks

7. DHCP Relay Agent Configuration Juniper Networks

8. Configure Power over Ethernet (PoE) interfaces on EX-series Switches

9. Configuring An Interface Range on EX-series Switches

10. Voice Data on Single Access Port (Supported LLDP-MED)

11. Tổng hợp cấu hình - Quit Configuration


THỰC HIỆN

1. Cấu hinh căn bản Juniper Networks

Commands Diễn Giải
cli vào mode cli
set date 202104151020.30 Thiết lập thời gian là: 10 giờ 20 phút 30 giây ngày 15 tháng 04 năm 2021 (định dạng là: YYYYMMDDHHMM.ss)
configure vào mode config để bắt đầu cấu hình
set system host-name R1-EX3400-24P Đặt tên cho thiết bị là R1-EX3400-24P
set system login message "===Đây là Switch R1-EX3400-24P===" Khi truy cập vào thiết bị sẽ hiển thị banner có nội dung là: "===Đây là Switch R1-EX3400-24P==="
set system domain-name 8.8.8.8 Đặt DNS mặc định có IP là: 8.8.8.8
set system time-zone GMT+7 Đặt múi giờ là GMT+7
set system root-authentication plain-text-password Đặt password cho user root(sau khi enter sẽ nhập password đặt enter để xác nhận lại password)
set system login user admin class super-user authentication plain-text-password Tạo user admin đặt password cho user admin(sau khi enter sẽ nhập password đặt enter để xác nhận lại password)
set system service telnet Cài đặt service telnet
set system service SSH Cài đặt service SSH
set system services web-management https system-generated-certificate Cài đặt service web và sử dụng https
commit check kiểm tra thông tin cấu hình trước khi lưu
commit lưu cấu hình
show | compare So sánh/kiểm tra cấu hình đã thay đổi thế nào


2. Tạo vlan Juniper Networks

Commands Diễn Giải
set vlans vlan-10 vlan-id 10 Tạo vlan có tên là vlan-10 và id của vlan là 10
set vlans vlan-10 description "==Used for MainOffice==" vlan-10 có phần chú thích là "==Used for MainOffice=="
show vlans Hiển thị các vlan đã được tạo trên switch


3. Đặt IP Address/Configure Interface or Vlan IP Address Juniper Networks

3.1 Đặt IP address trên interface

Commands Diễn Giải
set interfaces ge-0/0/10 unit 0 family inet address 10.10.10.254/24 Gán interface ge-0/0/10 có địa chỉ IP là 10.10.10.254/24
set interfaces ge-0/0/10 unit 0 description "==Dat IP cho interface==" Interface ge-0/0/10 có phần chú thích là "==Dat IP cho interface=="
show interfaces ge-0/0/10 Xem các thông tin đã được cấu hình trên interface ge-0/0/10
run show interfaces terse Hiển thị thông tin trạng thái của tất cả interface trong Juniper (tương đương lệnh show ip interface brief trong cisco )
run show interfaces ge-0/0/10 terse Hiển thị thông tin trạng thái up/down, hiển thị thông tin IP được cấu hình trên interface ge-0/0/10

3.2 Đặt IP address trên interface vlan

Commands Diễn Giải
set vlans vlan-11 vlan-id 11 Tạo vlan có tên là vlan-11 và id của vlan là 11
set interfaces irb unit 11 family inet address 11.11.11.254/24

HOẶC

set interfaces irb.11 family inet address 11.11.11.254/24
Interface irb.11 (trong Juniper interface irb dùng cho interface vlan) có địa chỉ IP address là 11.11.11.254/24


vì irb unit 11 có thể viết là irb.11
set vlans vlan-11 l3-interface irb.11 Gán interface irb.11 vào interface vlan-11, hoặc cũng có thể hiểu là gán IP 11.11.11.254 vào interface vlan-11

3.3 Đặt IP address trên interface me0 Managenment-MGMT

Commands Diễn Giải
set interfaces me0 unit 0 family inet address 192.168.123.254/24 Gán interface me0 (là interface Managenment) có địa chỉ IP là 192.168.123.254/24

Noted: Juniper chỉ chấp nhận việc đặt IP trên subInterface, nên mỗi khi đặt ip chúng ta phải gõ thêm theo cú pháp là tên interface unit <số> hoặc interface.<số>. 
ví dụ
irb unit 11 tương đương irb.11
- ge-0/0/10 unit 0 tương đương ge-0/0/10.0


* Kiểm tra thông tin cấu hình interface vlan 11:

Commands Kết quả

show vlans
vlan-11 {
       vlan-id 11;
       l3-interface irb.11;
}

show interfaces irb
unit 11 {
     family inet {
         address 11.11.11.254/24;
     }
}

4. Interface-mode (Access/Trunking) Juniper EX Series

Commands Giải Thích
set interfaces ge-1/0/11 unit 0 family ethernet-switching interface-mode access Gán interfaces ge-1/0/11 là mode access
set interfaces ge-1/0/11 unit 0 family ethernet-switching vlan members vlan-11 Interfaces ge-1/0/11 thuộc vlan-11
set interfaces ge-1/0/12 unit 0 family ethernet-switching interface-mode trunk Gán interfaces ge-1/0/12 là mode trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching vlan members all Interfaces ge-1/0/12 cho phép tất cả các vlan có trên switch đi qua
run show interfaces ge-1/0/12.0
Kiểm tra trunk trên interface ge-1/0/12.0 nếu có cấu hình thì
Flash: Trunk-Mode 
run show ethernet-switching interface Kiểm tra vlan members trên trunk hay trunk cho phép những vlan nào đi qua

Noted: Một số dòng thiết bị hiểu là port-mode thay cho vì interface-mode

5. Configuring Static Route Preferences/Default Route Juniper Networks

Commands Giải Thích
set routing-options static route 0.0.0.0/0 next-hop 10.10.10.1 default route trỏ về 10.10.10.1
set routing-options static route 0.0.0.0/0 preference 11 Cài đặt độ ưu tiên (AD) là 11
run show route Kiểm tra thông tin routing table

* Kiểm tra thông tin route đã cấu hình

Commands Kết quả

show routing-options
nonstop-routing;
       static {
route 0.0.0.0/0 next-hop 10.10.10.1; }


6. DHCP Server Configuration Juniper Networks

Commands Diễn Giải
set access address-assignment pool dhcp-vlan-11 family inet network 11.11.11.0/24 - Cấu hình pool DHCP có tên là dhcp-vlan-11
- Network cho pool dhcp-vlan-11 là 11.11.11.0/24
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 low 11.11.11.11 Địa chỉ thấp nhất có thể cấp cho cho các DHCP Client là 11.11.11.11
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 high 11.11.11.200 Địa chỉ cao nhất có thể cấp cho cho các DHCP Client là 11.11.11.200
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.8.8 Thiết lập DNS Server thứ nhất cho DHCP Client là 8.8.8.8
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.4.4 Thiết lập DNS Server thứ hai cho DHCP Client là 8.8.4.4
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes router 11.11.11.254 Thiết lập default gateway cho DHCP Client là 11.11.11.254
set system services dhcp-local-server group dhcp-vlan-11 interface irb.11 Nếu có thiết bị trong interface irb.11(vlan-11) xin DHCP thì sẽ sử dụng pool có tên dhcp-vlan-11
show access address-assignment Hiển thị thông tin các pool DHCP hiện có trên switch
show system services dhcp-local-server Hiển thị thông tin các interface/vlan có thể sử dụng DHCP server trên switch

* Kiểm tra thông tin DHCP server

Commands Kết quả

show access address-assignment
pool dhcp-vlan-11 {
      family inet {
             network 11.11.11.0/24;
             range range-vlan-11 {
                  low 11.11.11.11;
                  high 11.11.11.200;
             }
             dhcp-attributes {
                    name-server {
                          8.8.8.8;
                          8.8.4.4;
                   }
                   router {
                             11.11.11.254;
                  }
              }
      }
}

show system services dhcp-local-server
group dhcp-vlan-11 {
        interface irb.11;
}


7. DHCP Relay Agent Configuration Juniper Networks


Commands Diễn Giải
set forwarding-options dhcp-relay server-group DHCP-RELAY 172.16.126.11 172.16.126.11 là địa chỉ IP của DHCP Server (đây là DHCP server không nằm trên switch, phải đảm bảo hệ thống network phải routing đến được server này), chúng ta có thể có nhiều DHCP Server
set forwarding-options dhcp-relay active-server-group DHCP-RELAY Chỉ định/kích hoạt tên của Server/Nhóm server DHCP được phép relay/iphelper
set forwarding-options dhcp-relay group DHCP-RELAY interface irb.96 Nếu các thiết bị (client) trong vlan sử dụng gateway là ip của interface irb.96 khi xin DHCP thì interface irb.96 sẽ chuyển thông tin đến DHCP server và nhận kết quả trả về từ DHCP server sau đó phản hồi lại cho client
show forwarding-options Hiển thị thông tin DHCP relay đang cấu hình trên switch

Noted: Nếu interface irb.97 muốn dùng dhcp relay chúng ta chỉ cấu hình thêm thêm: "set forwarding-options dhcp-relay group DHCP-RELAY interface irb.97" là đủ


8. Configure Power over Ethernet (PoE) interfaces on EX-series Switches

Commands Diễn Giải
set poe interface ge-0/0/0 Bật PoE trên interface ge-0/0/0
set poe interface all Bật PoE trên tất cả các interface
set poe interface all priority high Bật và thiết lập priority ở mức cao
set poe interface all maximum-power 14 Thiết lập maximum-power là 14 wattage, mặc định là của switch 15.4
show poe interface Kiểm tra trạng thái PoE đã cấu hình trên switch


9. Configuring An Interface Range on EX-series Switches


Commands Diễn Giải
set interfaces interface-range range-port-TEST member-range ge-1/0/0 to ge-1/0/10

HOẶC

set interfaces interface-range range-port-TEST member "ge-1/0/[0-10]"

Tạo nhóm có tên range-port-TEST gồm các interface từ ge-1/0/0 đến ge-1/0/10
set interfaces interface-range range-port-TEST unit 0 family ethernet-switching vlan members vlan-11 Gán nhóm interface có tên range-port-TEST thuộc vlan có tên là vlan-11
set interfaces interface-range range-port-TEST disable Disable các port thuộc range có tên range-port-TEST (disable tương đương shutdown trong cisco)
show interfaces interface-range range-port-TEST Hiển thị thông tin đã cấu hình của range interface có tên range-port-TEST (show trong mode config)
Range port tham khảo

10. Voice Data on Single Access Port (Supported LLDP-MED)



Commands Diễn Giải
set protocols lldp interface all Đảm bảo LLDP enable trên interface (ở đây chúng tôi mở trên tất cả các interface)
set protocols lldp-med interface ge-0/0/2 Enable LLDP-MED trên cổng ge-0/0/2 là cổng đấu nối điện thoại - Voice IP
set protocols lldp-med fast-start 6 Thiết lập số gói tin (6 gói) quảng bá LLDP-MED sau khi detect thiết bị
set vlans vlan-125 vlan-id 125 Đảm bảo vlan-125 dùng cho voice tồn tại trên switch
set vlans vlan-119 vlan-id 119 Đảm bảo vlan-119 dùng cho Data tồn tại trên switch
set switch-options voip interface ge-0/0/2 vlan vlan-125 Cấu hình voice vlan cho interface ge-0/0/2
set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access Chuyển ge-0/0/2 là mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members vlan-119 Gán ge-0/0/2 làm member của vlan-119 (là vlan dùng cho Data)

*Kiểm tra cấu hình:

- show lldp: đảm bảo LLDP-MED đã bật trên interface ge-0/0/2

- show vlan: đảm bảo interface ge-0/0/2 thuộc vào 2 vlan và trạng thái đang active (có dấu sao là đang active)


11. Tổng hợp cấu hình - Quit Configuration

1. Cấu Hình Căn Bản
cli
set date 202104151020.30
configure
set system host-name R1-EX3400-24P
set system login message "===Đây là Switch R1-EX3400-24P==="
set system domain-name 8.8.8.8
set system time-zone GMT+7
set system root-authentication plain-text-password
set system login user admin class super-user authentication plain-text-password
# nhập password muốn đặt
# xác nhận lại password
set system service telnet
set system service SSH
set system services web-management https system-generated-certificate
commit
Noted: Khi copy thì copy đến hết dòng số 9 sau đó đặt password mới và xác nhận password, và tiếp tục copy dán các dòng còn lại

2. Tạo Vlan
set vlans vlan-10 vlan-id 10
set vlans vlan-10 description "==Used for MainOffice=="             
show vlans

3.1 Đặt IP Trên Interface
set interfaces ge-0/0/10 unit 0 family inet address 10.10.10.254/24
set interfaces ge-0/0/10 unit 0 description "==Dat IP cho interface=="
show interfaces ge-0/0/10 

3.2 Đặt IP Cho Vlan
set vlans vlan-11 vlan-id 11
set interfaces irb.11 family inet address 11.11.11.254/24
set vlans vlan-11 l3-interface irb.11
3.3 Đặt IP Port MGMT
set interfaces me0 unit 0 family inet address 192.168.123.254/24
4.1 Interface Mode-Access
set interfaces ge-1/0/11 unit 0 family ethernet-switching interface-mode access
set interfaces ge-1/0/11 unit 0 family ethernet-switching vlan members vlan-11        
4.2 Interface Mode-Trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-1/0/12 unit 0 family ethernet-switching vlan members all        
5. Static Route/Default Route
set routing-options static route 0.0.0.0/0 next-hop 10.10.10.1
set routing-options static route 0.0.0.0/0 preference 11        
6. DHCP Server
set access address-assignment pool dhcp-vlan-11 family inet network 11.11.11.0/24
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 low 11.11.11.11
set access address-assignment pool dhcp-vlan-11 family inet range range-vlan-11 high 11.11.11.200
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.8.8
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes name-server 8.8.4.4
set access address-assignment pool dhcp-vlan-11 family inet dhcp-attributes router 11.11.11.254
set system services dhcp-local-server group dhcp-vlan-11 interface irb.11
7. HDCP Relay Agent
set forwarding-options dhcp-relay server-group DHCP-RELAY 172.16.126.11
set forwarding-options dhcp-relay active-server-group DHCP-RELAY
set forwarding-options dhcp-relay group DHCP-RELAY interface irb.96
8. Configure Power over Ethernet - PoE
set poe interface ge-0/0/0
set poe interface all
set poe interface all priority high
set poe interface all maximum-power 14
9.1 Cấu Hình Range-Port Vào Vlan
set interfaces interface-range range-port-TEST member-range ge-1/0/0 to ge-1/0/10
set interfaces interface-range range-port-TEST unit 0 family ethernet-switching vlan members vlan-11        
show interfaces interface-range range-port-TEST
9.2 Cấu Hình Range-Port Theo Regular Expression + Disable Các Port Trong Range
set interfaces interface-range range-port-TEST member "ge-1/0/[0-10]"
set interfaces interface-range range-port-TEST disable        
10. Voice Data on Single Access Port
set protocols lldp interface all
set protocols lldp-med interface ge-0/0/2
set protocols lldp-med fast-start 6
set vlans vlan-125 vlan-id 125
set vlans vlan-119 vlan-id 119
set switch-options voip interface ge-0/0/2 vlan vlan-125
set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members vlan-119

Link tham khảo từ juniper

Link tham khảo 


Xong!

P/s: để xóa cấu hình của interface dùng delete

ví dụ: 
- Xóa cấu hình của interface ge-0/0/10: delete interface ge-0/0/10 
- Hoặc của range: delete interfaces interface-range range-vlan-TEST member-range ge-0/0/10 to ge-0/0/14



/*header slide*/