- CCNA TTG Training Center - Download
- CCNA networklession - Download
- CCNP Switch networklession - Download
- CCNP Route networklession - Download
- CCNP Tshoot networklession - Download
- 101 Lab CCNA - Download
Library, Share Tài Liệu Cisco
Network Automation #008 - Netmiko Finding Device IP Addresses Connected To Juniper - JunOS Switch
Nên tham khảo bài Juniper - JunOS (mục 2) trước khi xem bài này
YÊU CẦU:
Dùng thư viện Netmiko trong python để SSH vào switch Juniper - JunOS để tìm các thiết bị hiện tại đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó. Các địa chỉ IP cần tìm được lưu trữ trong file "device_list.csv".
Kết quả tìm được in ra màn hình và lưu vào file "Show_arp_Ketqua_192.168.0.1.csv"
THỰC HIỆN:
1. Chuẩn bị file danh sách thiết bị có dạng
2. Code
'''
Tìm thiết bị đang gắng vào port nào trên local switch khi biết địa chỉ IP của nó
Danh sách các IP cần tìm để trong file "device_list.csv"
(Điều kiện là thiết bị Juniper cần kết nối đã được cấu hình SSH)
Kết quả tìm được in ra màn hình và lưu vào file "Show_arp_Ketqua_192.168.0.1.csv"
Câu lệnh chính dùng trong bài:
- show arp hostname < địa chỉ ip cần tìm>
- show ethernet-switching table <địa chỉ mac cần tìm>
'''
import netmiko # import thư viện netmiko
import os
# Thông tin thiết bị cần SSH vào (định nghĩa dictionnary)
Sw_1 = {
"host":"192.168.0.1",
"username":"admin",
"password":"admin1234@core",
"device_type":"juniper_junos"
}
print("Connecting to a host: " + Sw_1["host"] + "...") # Hiển thị thông báo kết nối tới
# dùng hàm ConnectHandler trong thư viện netmiko để kết nối với Sw_1 với các thông tin đã định nghĩa trong dictionnary
net_connect = netmiko.ConnectHandler(**Sw_1)
print("Connected successfully\n")
with open ("device_list.csv","r") as rfile: # mở file
keys = rfile.readline() # lấy dòng đầu tiên
values = rfile.read() # các dòng còn lại là giá trị cần gán vào dict
# print(keys)
# print(values)
'''
để remove xuống dòng (newline) chúng ta có thể dùng
print(keys,end="")
'''
file_ketqua = "Show_arp_Ketqua_" + Sw_1["host"] + ".csv" # định nghĩa tên file cần ghi kết quả
file_header = keys.rstrip() + ",Vlan,Mac Address,MAC Flags,Logical Interface\n" # bỏ newline (\n) ở cuối dòng và nối thêm chuỗi để ghi vào file chuẩn bị để chứa kết quả show mac address và chèn newline vào cuối
f = open(file_ketqua,"w")
# print(file_header)
f.write(file_header)
f.flush() # thực hiện ghi
f.close() # đóng file để giải phóng bộ nhớ
print ("*" * 20 + "KET QUA" + "*" * 20)
for values in values.splitlines(): # trả về một chuỗi tương ứng là một dòng trong biến values
values = values.split(",") # mỗi dòng chuyển thành list
ip_addr = values[0] # giá trị của cột đầu tiên là địa chỉ IP cần lấy ra
ip_description = values[1]
# print(ip_addr)
# print(ip_description)
# print(values)
print("*" + ip_addr + ":") # In ra IP đang cần show
net_connect.send_command("ping" + " " + ip_addr + " " + "count 4") # ping (ping 4 gói) địa chỉ IP cần kiểm tra để switch cập nhật vào bảng MAC
show_arp = "show arp" + " " + "hostname" + " " + ip_addr
show_arp = net_connect.send_command(show_arp) # thực hiện lênh show arp với chính IP cần tìm
#print (show_arp)
# In ra dòng thứ nhì trong chuỗi
# print (show_arp.splitlines()[1])
# lấy dòng thứ nhì và phân ra từng cụm
fields = show_arp.splitlines()[1].split()
# lấy cụm đầu tiên (là địa chỉ MAC) tính từ trái sang
mac_addr = fields[0]
# print (mac_addr)
show_mac_addr = "show ethernet-switching table" + " " + mac_addr
show_mac_addr = net_connect.send_command(show_mac_addr) # thực hiện lệnh show
print(show_mac_addr)
show_mac_addr = show_mac_addr.splitlines()[8].split() # lấy dòng thứ 8 chuyển thành list
#print(show_mac_addr) # In kết quả show ra màn hình
print() # In ra dòng trắng
#print(type(show_mac_addr))
#print(type(values))
for i in [6,5,3]:
del show_mac_addr[i] # thực hiện xóa các phần tử không cần lấy
show_mac_addr = values + show_mac_addr # thực hiện nối thông tin ban đầu và kết quả
#print(show_mac_addr)
show_mac_addr = ",".join(show_mac_addr) + "\n" # convert list sang string và thêm "," vào giữa mỗi cụm
f = open(file_ketqua,"a")
f.write(show_mac_addr) # thực hiện ghi thêm kết quả vào file kết quả
path = os.getcwd() # lấy đường dẫn hiện tại
print("*" * 20 + "KẾT QUẢ ĐƯỢC LƯU TẠI" + "*" * 20)
print(r"{}".format(path))
print(file_ketqua)
print("*" * 60 + "\n")
3. Kết quả:
Connecting to a host: 192.168.0.1...Connected successfully********************KET QUA*********************172.16.125.11:MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MACSE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)Ethernet switching table : 109 entries, 109 learnedRouting instance : default-switchVlan MAC MAC Age Logical NH RTRname address flags interface Index IDvlan-125 c0:74:ad:32:2d:3c D - ge-1/0/1.0 0 0*172.16.126.11:MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MACSE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)Ethernet switching table : 109 entries, 109 learnedRouting instance : default-switchVlan MAC MAC Age Logical NH RTRname address flags interface Index IDvlan-126 d4:f5:ef:09:c0:1e D - ge-1/0/3.0 0 0********************KẾT QUẢ ĐƯỢC LƯU TẠI********************C:\vck\LABShow_arp_Ketqua_192.168.0.1.csv************************************************************[Finished in 17.5s]
Nội dung của file Show_arp_Ketqua_192.168.0.1.csv có dạng
Network Automation #000 - Netmiko Basic SSH To Router With Command Show
conf thostname R_1ip domain name NETMIKO.labno ip domain-lookupbanner motd #===R_1 NETMIKO LAB===#username admin privilege 15 password admin1234service password-encryptionline con 0logging synchronouslogin localexitline vty 0 4login localtransport input allcrypto key generate rsa general-keys modulus 1024ip ssh version 2interface Et0/0no shutdownip address 192.168.0.1 255.255.255.0description ===Connect to PC===exit!endwri
#!/usr/bin/env python3
import netmiko
# Định nghĩa thông tin thiết bị trong dictionary (thông tin cấu hình trong phần chuẩn bị cấu hình)
device_info = {
"host": "192.168.0.1",
"port": 22,
"username": "admin",
"password": "admin1234",
"device_type": "cisco_ios"
}
print("Connecting to {}...".format(device_info["host"])) # print ra dong Connecting to + IP được định nghĩa ở trong dictionnary
net_connect = netmiko.ConnectHandler(**device_info) # Dùng hàm ConnectHandler trong thư viện netmiko để kế nối đến thiết bị
print("Connected successfully") # in ra dòng kết nối thành công
net_connect.enable() # vào mode enable
#net_connect.config_mode() # vào mode config terminal
while True:
hostname = net_connect.find_prompt() # Trả về dấu nhắc hiện tại
command = input(hostname) # in ra những gì trước dấu nhắc (trường hợp này là hostname)
if command != "exit" and command != "quit": # nếu không không phải là exit hay quit thì thực hiện lệnh show
output = net_connect.send_command(command) # thực hiện lệnh show vừa gõ
print(output) # in qa kết quả thực hiện lênh show
else:
break # kết thúc vòng lặp while (khi chúng ta gõ exit hay quit)
net_connect.disconnect()
- Thực hiện ở Command Prompt
c:\Python>python Demo.pyConnecting to 192.168.0.1...Connected successfullyR_1#
- Tiếp tục thực hiện lênh show ip int bri
R_1#show ip int briInterface IP-Address OK? Method Status ProtocolEthernet0/0 192.168.0.1 YES NVRAM up upEthernet0/1 unassigned YES NVRAM administratively down downEthernet0/2 unassigned YES NVRAM administratively down downEthernet0/3 unassigned YES NVRAM administratively down downR_1#
- Hoặc thực hiện bất cứ lệnh show nào bạn thích
- Chụp hình kết quả thực hiện
Mô Hình Mạng Cho Doanh Nghiệp Vừa & Nhỏ - Bài 7
Nên xem bài cấu hình căn bản trước xem bài này
Sơ đồ LAB:
STT | Tên Thiết Bị | Interface | IP Address | Subnet Mask | Gateway/Default Route |
---|---|---|---|---|---|
1 | Internet | Lookback 8 | 8.8.8 | 255.0.0.0 | |
Et0/0 | 200.1.1.1 | 255.255.255.252 | |||
2 | ISP-Router | Et0/0 | 200.1.1.2 | 255.255.255.0 | 200.1.1.1 |
Et0/1 | 125.234.102.241 | 255.255.255.248 | |||
3 | Firewall | Et0/1 | 125.234.102.243 | 255.255.255.248 | 125.234.102.241 |
Et0/1 | 192.168.200.1 | 255.255.255.0 | |||
4 | Core | Et0/1 | 192.168.200.2 | 255.255.255.0 | 192.168.200.1 |
Vlan100 | 192.168.100.254 | 255.255.255.0 | |||
Vlan101 | 192.168.101.254 | 255.255.255.0 | |||
Vlan102 | 192.168.102.254 | 255.255.255.0 | |||
Vlan103 | 192.168.103.254 | 255.255.255.0 | |||
5 | DHCP Server | Vlan100 | 192.168.100.100 | 255.255.255.0 | 192.168.100.254 |
6 | PC1 | Eth0 | 192.168.101.101 | 255.255.255.0 | 192.168.101.254 |
7 | PC2 | Eth0 | 192.168.102.102 | 255.255.255.0 | 192.168.102.254 |
8 | PC3 | Eth0 | DHCP | ||
9 | PC3 | Eth0 | DHCP |
YÊU CẦU:
- Tạo các vlan 101, 102,103 và thực hiện đặt IP theo sơ đồ
- Tạo vlan 500 và gán port Et0/2, Et0/3 vào vlan 500
- Đặt IP Address và Default Route như sơ đồ
- Cấu hình các pool DHCP cho vlan 101, 102, 103
- Vlan 103 chỉ cấp DHCP trong khoảng từ 192.168.103.104 đến 192.168.103.253
- Tạo vlan 100, đặt ip cho vlan 100 theo sơ đồ, gán port Et0/0 vào vlan 100
- Cấu hình dhcp relay agent cho vlan 101,102,103 đảm bảo các PC trong các vlan có thể lấy được địa chỉ IP do DHCP_Server 192.168.100.100 cấp
THỰC HIỆN:
1. Đặt IP theo sơ đồ- Internet:
conf thostname Internetinterface Loopback8no shutdownip address 8.8.8.8 255.0.0.0exitinterface et0/0ip address 200.1.1.1 255.255.255.252no shendwri
- ISP-Router:
conf thostname ISP-Routerinterface et0/0ip address 200.1.1.2 255.255.255.252no shexitinterface et0/1ip address 125.234.102.241 255.255.255.248no shendwri
- Firewall:
conf thostname Firewallinterface et0/2ip address 125.234.102.243 255.255.255.248no shexitinterface et0/1ip address 192.168.200.1 255.255.255.248no shendwri
- Switch Core/Layer3:
conf thostname Coreinterface et0/1no switchportip address 192.168.200.2 255.255.255.248no shendwri
- Tạo các vlan 101, 102,103 và thực hiện đặt IP theo sơ đồ
conf tvlan 101int vlan 101ip address 192.168.101.254 255.255.255.0no shexitvlan 102int vlan 102ip address 192.168.102.254 255.255.255.0no shexitvlan 103int vlan 103ip address 192.168.103.254 255.255.255.0no shendwri
- Tạo vlan 500 và gán port Et0/2, Et0/3 vào vlan 500
conf tvlan 500exitint et0/2sw mode accesssw acc vlan 500exitint et0/3sw mode accesssw acc vlan 500endwri
- Cấu hình
conf tint et1/1switchport trunk encapsulation dot1qswitchport mode trunkswitchport trunk allowed vlan allendwri
conf thostname Acc01in et0/0switchport trunk encapsulation dot1qswitchport mode trunkswitchport trunk allowed vlan allendwri
- Kiểm tra:
Core#show interfaces trunkPort Mode Encapsulation Status Native vlanEt1/1 on 802.1q trunking 1Port Vlans allowed on trunkEt1/1 1-4094Port Vlans allowed and active in management domainEt1/1 1,100-103,500Port Vlans in spanning tree forwarding state and not prunedEt1/1 1,100-103,500Core#
Acc01#show interfaces trunkPort Mode Encapsulation Status Native vlanEt0/0 on 802.1q trunking 1Port Vlans allowed on trunkEt0/0 1-4094Port Vlans allowed and active in management domainEt0/0 1,101-102Port Vlans in spanning tree forwarding state and not prunedEt0/0 1,101-102Acc01#
- Cấu hình:
conf tvlan 101vlan 102exitint et0/1sw mode accesssw acc vlan 101exitint et0/2sw mode accesssw acc vlan 102endwri
- Kiểm tra:
Acc01#show vlanVLAN Name Status Ports---- -------------------------------- --------- -------------------------------1 default active Et0/3101 VLAN0101 active Et0/1102 VLAN0102 active Et0/21002 fddi-default act/unsup1003 token-ring-default act/unsup1004 fddinet-default act/unsup1005 trnet-default act/unsup
PC1> ping 192.168.102.10284 bytes from 192.168.102.102 icmp_seq=1 ttl=63 time=1.830 ms84 bytes from 192.168.102.102 icmp_seq=2 ttl=63 time=1.349 ms84 bytes from 192.168.102.102 icmp_seq=3 ttl=63 time=2.090 ms84 bytes from 192.168.102.102 icmp_seq=4 ttl=63 time=1.659 ms84 bytes from 192.168.102.102 icmp_seq=5 ttl=63 time=1.987 msPC1>
PC2> ping 192.168.101.10184 bytes from 192.168.101.101 icmp_seq=1 ttl=63 time=2.088 ms84 bytes from 192.168.101.101 icmp_seq=2 ttl=63 time=1.770 ms84 bytes from 192.168.101.101 icmp_seq=3 ttl=63 time=1.893 ms84 bytes from 192.168.101.101 icmp_seq=4 ttl=63 time=1.721 ms84 bytes from 192.168.101.101 icmp_seq=5 ttl=63 time=1.349 msPC2>
5. Tương tự cấu hình trunk trên cổng đấu nối giữa Core switch và Acc02; trên Acc02 tạo vlan 102, 103; gán port Et0/2 vào vlan 102 và port Et0/3 vào vlan 103.
- Cấu hình trunk
conf tint et1/2switchport trunk encapsulation dot1qswitchport mode trunkswitchport trunk allowed vlan allendwri
conf thostname Acc02in et0/0switchport trunk encapsulation dot1qswitchport mode trunkswitchport trunk allowed vlan allendwri
- Gán port vào vlan
conf tvlan 102vlan 103exitint et0/2sw mode accesssw acc vlan 102exitint et0/3sw mode accesssw acc vlan 103endwri
- Kiểm tra trên Acc02:
Acc02#show interfaces trunkPort Mode Encapsulation Status Native vlanEt0/0 on 802.1q trunking 1Port Vlans allowed on trunkEt0/0 1-4094Port Vlans allowed and active in management domainEt0/0 1,102-103Port Vlans in spanning tree forwarding state and not prunedEt0/0 1,102-103Acc02#
Acc02#show vlanVLAN Name Status Ports---- -------------------------------- --------- -------------------------------1 default active Et0/1102 VLAN0102 active Et0/2103 VLAN0103 active Et0/31002 fddi-default act/unsup1003 token-ring-default act/unsup1004 fddinet-default act/unsup1005 trnet-default act/unsup{...}Acc02#
- Đặt IP Address và Default Route như sơ đồ
conf thostname DHCP_Serverint et0/0ip address 192.168.100.100 255.255.255.0no shexitip route 0.0.0.0 0.0.0.0 192.168.100.254endwri
- Cấu hình các pool DHCP cho vlan 101, 102, 103
conf tip dhcp pool vlan_101network 192.168.101.0 255.255.255.0dns-server 8.8.8.8default-router 192.168.101.254lease 0 0 10exitip dhcp pool vlan_102network 192.168.102.0 255.255.255.0dns-server 8.8.8.8default-router 192.168.102.254lease 0 0 10exitip dhcp pool vlan_103network 192.168.103.0 255.255.255.0dns-server 8.8.8.8default-router 192.168.103.254lease 0 0 10endwri
Noted: Ở đây chúng tôi lấy router của cisco làm DHCP server, các bạn cũng có thể thay thế bằng Windows, Linux, ...
- Vlan 103 chỉ cấp DHCP trong khoảng từ 192.168.103.104 đến 192.168.103.253
conf tip dhcp excluded-address 192.168.103.1 192.168.103.103ip dhcp excluded-address 192.168.103.254endwri
- Tạo vlan 100, đặt ip cho vlan 100 theo sơ đồ, gán port Et0/0 vào vlan 100
conf tvlan 100int vlan 100ip address 192.168.100.254 255.255.255.0no shexitint et0/0sw mode accesssw acc vlan 100endwri
- Cấu hình dhcp relay agent cho vlan 101,102,103 đảm bảo các PC trong các vlan có thể lấy được địa chỉ IP do DHCP_Server 192.168.100.100 cấp
conf tint vlan 101ip helper-address 192.168.100.100int vlan 102ip helper-address 192.168.100.100int vlan 103ip helper-address 192.168.100.100endwri
PC3> ip dhcpDDORA IP 192.168.102.1/24 GW 192.168.102.254PC3>
PC4> ip dhcpDDORA IP 192.168.103.104/24 GW 192.168.103.254PC4>
DHCP_Server#show ip dhcp bindingBindings from all pools not associated with VRF:IP address Client-ID/ Lease expiration TypeHardware address/User name192.168.102.1 0100.5079.6668.03 Jun 07 2021 06:19 AM Automatic192.168.103.104 0100.5079.6668.04 Jun 07 2021 06:16 AM AutomaticDHCP_Server#
- Cấu hình:
conf tip route 125.234.102.240 255.255.255.248 200.1.1.2endwri
- Kiểm tra:
Internet#show ip route staticCodes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter areaN1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route, H - NHRP, l - LISPa - application route+ - replicated route, % - next hop overrideGateway of last resort is not set125.0.0.0/29 is subnetted, 1 subnetsS 125.234.102.240 [1/0] via 200.1.1.2Internet#
9. Tạo các default route và thực hiện NAT trên overload trên Firewall đảm bảo tất cả các PC có thể ping được 8.8.8.8
- Tạo default route:
conf tip route 0.0.0.0 0.0.0.0 200.1.1.1endwri
conf tip route 0.0.0.0 0.0.0.0 125.234.102.241endwri
conf tip route 0.0.0.0 0.0.0.0 192.168.200.1endwri
- NAT overload trên Firewall:
conf tinterface Ethernet0/1ip nat insideexitinterface Ethernet0/2ip nat outsideexitip nat inside source list 1 interface Ethernet0/2 overloadaccess-list 1 permit anyaccess-list 1 deny anyendwri
conf t
ip route 192.168.100.0 255.255.255.0 192.168.200.2
ip route 192.168.101.0 255.255.255.0 192.168.200.2
ip route 192.168.102.0 255.255.255.0 192.168.200.2
ip route 192.168.103.0 255.255.255.0 192.168.200.2
end
wri
- Kiểm tra:
PC3> ping 8.8.8.884 bytes from 8.8.8.8 icmp_seq=1 ttl=252 time=2.684 ms84 bytes from 8.8.8.8 icmp_seq=2 ttl=252 time=3.233 ms84 bytes from 8.8.8.8 icmp_seq=3 ttl=252 time=2.536 ms84 bytes from 8.8.8.8 icmp_seq=4 ttl=252 time=2.128 ms84 bytes from 8.8.8.8 icmp_seq=5 ttl=252 time=2.252 msPC3>
PC4> ping 8.8.8.884 bytes from 8.8.8.8 icmp_seq=1 ttl=252 time=3.107 ms84 bytes from 8.8.8.8 icmp_seq=2 ttl=252 time=3.087 ms84 bytes from 8.8.8.8 icmp_seq=3 ttl=252 time=2.000 ms84 bytes from 8.8.8.8 icmp_seq=4 ttl=252 time=2.140 ms84 bytes from 8.8.8.8 icmp_seq=5 ttl=252 time=2.865 msPC4>
- Kiểm tra bảng NAT trên Firewall:
Firewall#show ip nat translationsPro Inside global Inside local Outside local Outside globalicmp 125.234.102.243:13030 192.168.102.1:13030 8.8.8.8:13030 8.8.8.8:13030icmp 125.234.102.243:13286 192.168.102.1:13286 8.8.8.8:13286 8.8.8.8:13286icmp 125.234.102.243:13542 192.168.102.1:13542 8.8.8.8:13542 8.8.8.8:13542icmp 125.234.102.243:13798 192.168.102.1:13798 8.8.8.8:13798 8.8.8.8:13798icmp 125.234.102.243:14054 192.168.102.1:14054 8.8.8.8:14054 8.8.8.8:14054icmp 125.234.102.243:10470 192.168.103.104:10470 8.8.8.8:10470 8.8.8.8:10470icmp 125.234.102.243:10726 192.168.103.104:10726 8.8.8.8:10726 8.8.8.8:10726icmp 125.234.102.243:10982 192.168.103.104:10982 8.8.8.8:10982 8.8.8.8:10982icmp 125.234.102.243:11238 192.168.103.104:11238 8.8.8.8:11238 8.8.8.8:11238icmp 125.234.102.243:11494 192.168.103.104:11494 8.8.8.8:11494 8.8.8.8:11494Firewall#
- Internet
- ISP-Router
- Firewall
- Core
- DHCP Server
- Acc01
- Acc02
conf t
hostname Internet
interface Loopback8
no shutdown
ip address 8.8.8.8 255.0.0.0
exit
interface et0/0
ip address 200.1.1.1 255.255.255.252
no sh
exit
ip route 125.234.102.240 255.255.255.248 200.1.1.2
end
wri
conf t
hostname ISP-Router
interface et0/0
ip address 200.1.1.2 255.255.255.252
no sh
exit
interface et0/1
ip address 125.234.102.241 255.255.255.248
exit
ip route 0.0.0.0 0.0.0.0 200.1.1.1
no sh
end
wri
conf t
hostname Firewall
interface et0/2
ip address 125.234.102.243 255.255.255.248
no sh
exit
interface et0/1
ip address 192.168.200.1 255.255.255.248
no sh
exit
interface Ethernet0/1
ip nat inside
interface Ethernet0/2
ip nat outside
ip nat inside source list 1 interface Ethernet0/2 overload
ip route 0.0.0.0 0.0.0.0 125.234.102.241
ip route 192.168.100.0 255.255.255.0 192.168.200.2
ip route 192.168.101.0 255.255.255.0 192.168.200.2
ip route 192.168.102.0 255.255.255.0 192.168.200.2
ip route 192.168.103.0 255.255.255.0 192.168.200.2
access-list 1 permit any
access-list 1 deny any
end
wri
conf t
hostname Core
interface Ethernet0/1
no switchport
ip address 192.168.200.2 255.255.255.248
no sh
exit
vlan 100
vlan 101
vlan 102
vlan 103
vlan 500
exit
interface Ethernet0/0
switchport mode access
switchport access vlan 100
exit
interface Ethernet0/2
switchport mode access
switchport access vlan 500
exit
interface Ethernet0/3
switchport mode access
switchport access vlan 500
exit
interface Vlan100
ip address 192.168.100.254 255.255.255.0
exit
interface Vlan101
ip address 192.168.101.254 255.255.255.0
ip helper-address 192.168.100.100
exit
interface Vlan102
ip address 192.168.102.254 255.255.255.0
ip helper-address 192.168.100.100
exit
interface Vlan103
ip address 192.168.103.254 255.255.255.0
ip helper-address 192.168.100.100
exit
interface Ethernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
interface Ethernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
ip route 0.0.0.0 0.0.0.0 192.168.200.1
end
wri
conf t
hostname DHCP_Server
int et0/0
ip address 192.168.100.100 255.255.255.0
no sh
exit
ip route 0.0.0.0 0.0.0.0 192.168.100.254
ip dhcp pool vlan_101
network 192.168.101.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.101.254
lease 0 0 10
exit
ip dhcp pool vlan_102
network 192.168.102.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.102.254
lease 0 0 10
exit
ip dhcp pool vlan_103
network 192.168.103.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.103.254
lease 0 0 10
exit
ip dhcp excluded-address 192.168.103.1 192.168.103.103
ip dhcp excluded-address 192.168.103.254
end
wri
conf t
hostname Acc01
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
interface Ethernet0/1
switchport mode access
switchport access vlan 101
exit
interface Ethernet0/2
switchport mode access
switchport access vlan 101
end
wri
conf t
hostname Acc02
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
interface Ethernet0/2
switchport mode access
switchport access vlan 102
exit
interface Ethernet0/3
switchport mode access
switchport access vlan 103
end
wri
10. Cấu hinh trên Core switch phải đảm bảo các PC trong LAN truy cập 8.8.8.8 phải đi đúng thứ tự Core -> Firewall -> ISP-Router -> Internet; tuy nhiên khi Firewall down các PC có thể truy cập được 8.8.8.8 theo thứ tự Core -> ISP-Router -> Internet
- Kiểm tra trước khi cấu hình:
Chúng ta thấy các gói tin đã đi đúng yêu cầu ban đầu: Core -> Firewall -> ISP-Router -> InternetPC1> tracer 8.8.8.8trace to 8.8.8.8, 8 hops max, press Ctrl+C to stop1 192.168.101.254 1.291 ms 1.047 ms 0.968 ms2 192.168.200.1 1.814 ms 1.523 ms 1.661 ms3 125.234.102.241 2.160 ms 2.112 ms 1.928 ms4 *200.1.1.1 2.586 ms (ICMP type:3, code:3, Destination port unreachable) *PC1>
- Cấu hình:
interface Vlan500ip address 125.234.102.242 255.255.255.248no shutexitip route 0.0.0.0 0.0.0.0 125.234.102.241 10endwri
interface Ethernet0/0ip nat outsideexitinterface Ethernet0/1ip nat insideexitip nat inside source list LAN-to-INTERNET interface Ethernet0/0 overloadip access-list extended LAN-to-INTERNETdeny ip 125.234.102.240 0.0.0.7 anypermit ip any anyexitip route 192.168.100.0 255.255.255.0 125.234.102.242ip route 192.168.101.0 255.255.255.0 125.234.102.242ip route 192.168.102.0 255.255.255.0 125.234.102.242ip route 192.168.103.0 255.255.255.0 125.234.102.242endwri
- Giải thích access-list:
- Kiểm tra sau khi cấu hình
Core#ping 8.8.8.8Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Core#ping 8.8.8.8 source vlan 101Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:Packet sent with a source address of 192.168.101.254!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 msCore#
PC1> tracer 8.8.8.8trace to 8.8.8.8, 8 hops max, press Ctrl+C to stop1 192.168.101.254 1.016 ms 0.841 ms 0.948 ms2 125.234.102.241 1.687 ms 1.561 ms 1.470 ms3 *200.1.1.1 2.417 ms (ICMP type:3, code:3, Destination port unreachable) *PC1>
P/s: Đã đúng yêu cầu tuy nhiên chúng ta có thể làm thêm IP SLA Tracking để kiểm tra IP đầu xa, nếu ping đến không được thì sẽ tư động điều chỉnh bản route cho phù hợp
11. IP SLA Tracking
- Cấu hình:
ip sla 2001icmp-echo 192.168.200.1threshold 5frequency 10exit!ip sla schedule 2001 life forever start-time now!track 1 ip sla 2001 reachabilityexit!no ip route 0.0.0.0 0.0.0.0 192.168.200.1ip route 0.0.0.0 0.0.0.0 192.168.200.1 track 1endwri
- Kiểm tra:
Core#show ip sla configuration 2001IP SLAs Infrastructure Engine-IIIEntry number: 2001Owner:Tag:Operation timeout (milliseconds): 5000Type of operation to perform: icmp-echoTarget address/Source address: 192.168.200.1/0.0.0.0Type Of Service parameter: 0x0Request size (ARR data portion): 28Verify data: NoVrf Name:Schedule:Operation frequency (seconds): 10 (not considered if randomly scheduled)Next Scheduled Start Time: Start Time already passedGroup Scheduled : FALSERandomly Scheduled : FALSELife (seconds): ForeverEntry Ageout (seconds): neverRecurring (Starting Everyday): FALSEStatus of entry (SNMP RowStatus): ActiveThreshold (milliseconds): 5Distribution Statistics:Number of statistic hours kept: 2Number of statistic distribution buckets kept: 1Statistic distribution interval (milliseconds): 20Enhanced History:History Statistics:Number of history Lives kept: 0Number of history Buckets kept: 15History Filter Type: NoneCore#
Core#show ip sla statisticsIPSLAs Latest Operation StatisticsIPSLA operation id: 2001Latest RTT: 1 millisecondsLatest operation start time: 08:18:23 EET Wed Jun 9 2021Latest operation return code: OKNumber of successes: 31Number of failures: 6Operation time to live: ForeverCore#
Core#debug ip routingIP routing debugging is onCore#
Core#conf tint et0/1shutCore(config-if)#*Jun 9 06:24:31.200: is_up: Ethernet0/1 0 state: 6 sub state: 1 line: 0*Jun 9 06:24:31.200: RT: interface Ethernet0/1 removed from routing table*Jun 9 06:24:31.200: RT: del 192.168.200.0 via 0.0.0.0, connected metric [0/0]*Jun 9 06:24:31.200: RT: delete subnet route to 192.168.200.0/29*Jun 9 06:24:31.200: RT: del 192.168.200.2 via 0.0.0.0, connected metric [0/0]*Jun 9 06:24:31.200: RT: delete subnet route to 192.168.200.2/32*Jun 9 06:24:31.200: RT: del 0.0.0.0 via 192.168.200.1, static metric [1/0]*Jun 9 06:24:31.200: RT: delete network route to 0.0.0.0/0*Jun 9 06:24:31.200: RT: default path has been cleared*Jun 9 06:24:31.200: RT:Core(config-if)#updating static 0.0.0.0/0 (0x0):via 125.234.102.241*Jun 9 06:24:31.200: RT: add 0.0.0.0/0 via 125.234.102.241, static metric [10/0]*Jun 9 06:24:31.200: RT: default path is now 0.0.0.0 via 125.234.102.241Core(config-if)#*Jun 9 06:24:33.194: %LINK-5-CHANGED: Interface Ethernet0/1, changed state to administratively downCore(config-if)#*Jun 9 06:24:33.194: is_up: Ethernet0/1 0 state: 6 sub state: 1 line: 0*Jun 9 06:24:34.199: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1, changed state to down*Jun 9 06:24:34.199: is_up: Ethernet0/1 0 state: 6 sub state: 1 line: 0Core(config-if)#*Jun 9 06:24:36.256: %TRACKING-5-STATE: 1 ip sla 2001 reachability Up->DownCore(config-if)#
Xong!
Cisco - Cấu Hình Căn Bản/Basic Configuration - Quit Configuration - Templates
NỘI DUNG:
1. Cấu hình căn bản
2. Basic System Management Configuration
3. Quit Configuration - Template
4. VLAN Trunking Protocol - VTP
5. NAT Overload/PAT - Allow Internal Users Access To The Internet
6. Trouble shooting - show commands
THỰC HIỆN:
1. Cấu hình căn bản
đang cập nhật...
STT | Yêu Cầu Cấu Hình | Commands | Giải Thích |
---|---|---|---|
1 | Privileged mode | enable | Tìm hiểu các mode tại đây |
2 | Global Configuration | conf t | Vào mode cấu hình, |
3 | exit | Quay ra một bật | |
4 | End | Quay ra Privileged mode | |
5 | Đặt tên cho thiết bị | hostname TenThietBi | Đặt tên cho thiết bị có tên là: TenThietBi |
6 | Đặt tên cho domain | ip domain name khanhvc.lab | Đặt trên cho domain có tên: khanhvc.lab (nhằm mục đích mã hóa dữ liệu) |
7 | no ip domain-lookup | Tắt chế độ phân giải domain sang ip (khi chúng ta gõ sai thiết bị không đị đơ khi chờ phân giải, rất khó chịu khi cấu hình nên tắt đi) | |
8 | Đặt tên login/banner | banner motd #===Core Switch IT Room===# | Khi chúng ta kết nối vào thiết bị sẽ hiển thị "===Core Switch IT Room===" |
9 | Cài đặt user và pass | username admin privilege 15 password itadmin | Username admin có password là itadmin và quyền là 15 (cao nhất) và bỏ qua enable password |
10 | Mã hóa password | service password-encryption | Kích hoạt mã hóa password trong file cấu hình |
11 | Remote Access | line con 0 | Vào mode console thứ 0 (tham khảo các kỹ thuật kết nối tại đây) |
logging synchronous | Đồng bộ thông báo console, Giữ nguyên những gì chúng ta đang gõ trên màn hình (thông báo sẽ không xen vào khi chúng ta đang gõ lệnh) | ||
login local | Sử dụng username và password trên thiết bị | ||
exit | Quay ra một bật | ||
line vty 0 4 | Vào mode vty-telnet. Tham khảo mục 2 - telnet | ||
login local | Sử dụng username và password trên thiết bị | ||
transport input all | Cho phép/chuyển qua tất cả các dịch vụ (telnet, ssh) | ||
crypto key generate rsa general-keys modulus 1024 | Tạo key khi mã hóa ssh | ||
ip ssh version 2 | Chuyển sang ssh version 2 | ||
12 | Tạo Vlan | vlan100 | Tạo vlan 100 |
name HR-Dept | Option - Tên của vlan 100 là HR-Dept | ||
13 | Đặt IP cho interface vlan | interface Vlan100 | Vào mode interface của vlan 100 |
no shutdown | Kích hoạt interface | ||
description ===Gateway cho vlan 100=== | Option - Chú thích cho interface | ||
ip address 192.168.100.254 255.255.255.0 | Đặt IP cho vlan 100 | ||
14 | Đặt IP trên interface | interface Ethernet0/0 | Vào mode interface của port Ethernet0/0 |
no switchport | Enable port layer3/Routed port (Trên switch mặt định là port layer 2) | ||
description ===Linked to Firewall=== | Option - Chú thích cho interface | ||
ip address 192.168.200.2 255.255.255.248 | Đặt IP tĩnh cho port Ethernet0/0 | ||
ip address dhcp | Interface Et0/0 sẽ xin IP động từ DHCP server | ||
ip address 192.168.0.1 255.255.255.0 secondary | Đặt IP thứ 2 trên 1 interface | ||
15 | Access Mode | interface Ethernet0/1 | Vào mode interface của port Ethernet0/1 |
switchport mode access | Chuyển interface Ethernet0/1 về mode access | ||
switchport access vlan 100 | Gán interface Ethernet0/1 vào vlan 100 | ||
16 | Trunking | interface Ethernet0/2 | Vào mode interface của port Ethernet0/2 |
switchport trunk encapsulation dot1q | Đóng gói chuẩn dot1q. (Có 1 số dòng sản phẩm không cần gõ dòng lệnh này) | ||
switchport mode trunk | Mode trunk | ||
switchport trunk allowed vlan all | Cho phép tất cả các vlan đi qua đường trunk | ||
17 | Routing | ip routing | Cho phép các IP của các vlan khác nhau có thể giao tiếp được với nhau |
18 | Default Route | ip route 0.0.0.0 0.0.0.0 200.2.2.1 | Trỏ default route về IP 200.2.2.1 |
19 | DHCP Server | ip dhcp pool vlan_101 | Tạo pool dhcp có tên pool vlan_101 |
network 192.168.101.0 255.255.255.0 | Lớp mạng cần cấp cho pool vlan_101 là: 192.168.101.0/24 | ||
dns-server 8.8.8.8 | DNS sẽ cấp cho pool là 8.8.8.8 | ||
default-router 192.168.101.254 | Default Gateway | ||
lease 0 0 10 | Thời gian clien xin cấp lại ip GIỜ PHÚT GIÂY | ||
20 | DHCP Exclude Address | ip dhcp excluded-address 192.168.101.254 | DHCP server sẽ không cấp phát địa chỉ 192.168.101.254 cho dhcp client |
ip dhcp excluded-address 192.168.101.1 192.168.101.50 | Các IP trong dãy từ 192.168.101.1 -> 50 sẽ không được cấp cho DHCP client | ||
21 | DHCP Relay Agent | interface Vlan101 | Vào mode interface của vlan 101 |
ip helper-address 192.168.100.100 | IP 192.168.100.100 sẽ chịu trách nhiệm cấp phát IP cho vlan 101 | ||
22 | VLAN Trunking Protocol - VTP | vtp domain khanhvc.lab | Đặt tên cho vtp domain |
vtp password vtpadmin | Đặt password cho vtp | ||
vtp version 2 | Chuyển vtp dùng version 2 | ||
vtp mode server | Cài đặt mode cho vtp. VTP có 3 mode là: Server, client và tranperrent | ||
vtp pruning | Tính năng này chỉ bật trên mode server | ||
23 | NAT Overload + ACL | interface Ethernet0/1 | Vào mode interface (Inside local - interface đấu nối hướng vào mạng LAN ) |
ip nat inside | Cấu hình NAT inside | ||
interface Ethernet0/2 | Interface Inside global (Cổng đấu nối hướng ra ISP) | ||
ip nat outside | Cấu hình NAT outside | ||
ip nat inside source list 1 interface Ethernet0/2 overload | Thực hiện việc dịch tất cả các địa chỉ IP nằm trong access-list 1 sang địa chỉ IP trên cổng Et0/2 | ||
access-list 1 permit any | Định nghĩa access-list 1 và cho phép tất cả các ip | ||
24 | Xóa cấu hình | erase startup-config | Xóa cấu trên Router/Switch |
delete vlan.dat | Nếu là switch chúng ta thực hiện thêm phần xóa các vlan (Tham khảo mục 2 xóa cấu hình) | ||
reload | Khởi động thiết bị | ||
25 | Lưu cấu hình | write memory | Thực hiện lưu cấu hình |
HOẶC copy running-config startup-config |
Lưu cấu hình đang chạy vào file khởi động |
||
26 | no service config | Tắt %Error opening tftp://255.255.255.255/xxxx (Timed out) |
2. Basic System Management Configuration
- 1. Router
- 2. Switch
conf t
hostname Router-KHANHVC
ip domain name khanhvc.lab
no ip domain-lookup
banner motd #===Router KHANHVC===#
username admin privilege 15 password itadmin
service password-encryption
line con 0
logging synchronous
login local
exit
line vty 0 4
login local
transport input all
crypto key generate rsa general-keys modulus 1024
ip ssh version 2
interface Gi0/0
no shutdown
ip address 192.168.1.254 255.255.255.0
description ===Connect to somewhere===
exit
!
end
wri
conf t
hostname Switch-KHANHVC
ip domain name khanhvc.lab
no ip domain-lookup
banner motd #===Switch KHANHVC===#
username admin privilege 15 password itadmin
service password-encryption
line con 0
logging synchronous
login local
exit
line vty 0 4
login local
transport input all
crypto key generate rsa general-keys modulus 1024
ip ssh version 2
!
interface Vlan1
no shutdown
description ===MGMT===
ip address 192.168.1.254 255.255.255.0
exit
end
wri
3. Quit Configuration - Template
- 1. Router
- 2. Layer3
- 3. Layer2
- 4.1. DHCP Server
- 4.2. DHCP Relay Agent
- 5. Voice Data
conf t
hostname Router-CE-LL
ip domain name khanhvc.lab
no ip domain-lookup
banner motd #===Router CE Leased-Line===#
username admin privilege 15 password itadmin
service password-encryption
line con 0
logging synchronous
login local
exit
line vty 0 4
login local
transport input all
crypto key generate rsa general-keys modulus 1024
ip ssh version 2
interface et0/0
no shutdown
ip address 200.2.2.2 255.255.255.252
description ===Linked to ISP===
ip nat outside
exit
!
interface et0/1
no shutdown
ip address 100.1.1.1 255.255.255.248
description ===Linked to Firewall===
ip nat inside
exit
!
ip route 0.0.0.0 0.0.0.0 200.2.2.1
ip nat inside source list LAN-to-INTERNET interface Ethernet0/0 overload
!
ip access-list extended LAN-to-INTERNET
deny ip 100.1.1.0 0.0.0.7 any
permit ip any any
exit
!
end
wri
conf t
hostname CoreSwitch
ip domain name khanhvc.lab
no ip domain-lookup
banner motd #===Core Switch IT Room===#
username admin privilege 15 password itadmin
service password-encryption
line con 0
logging synchronous
login local
exit
line vty 0 4
login local
transport input all
crypto key generate rsa general-keys modulus 1024
ip ssh version 2
!
interface Vlan1
no shutdown
description ===MGMT===
ip address 192.168.1.254 255.255.255.0
exit
vlan 100
interface Vlan100
no shutdown
description ===Server===
ip address 192.168.100.254 255.255.255.0
exit
vlan 101
interface Vlan101
no shutdown
description ===HR Dept.===
ip address 192.168.101.254 255.255.255.0
exit
!
ip routing
!
interface Ethernet0/0
no switchport
description ===Linked to Firewall===
ip address 192.168.200.2 255.255.255.248
no shutdown
exit
interface Ethernet0/1
description ===Linked to AD Server IP_100.100===
switchport mode access
switchport access vlan 100
no shutdown
exit
interface Ethernet0/2
description ===Linked to Access Switch===
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
!
ip route 0.0.0.0 0.0.0.0 200.2.2.1
!
end
wri
- Nếu tạo thêm vlan thì chúng ta nhân bản vlan lên ví dụ vlan 102
conf tvlan 102interface Vlan102no shutdowndescription ===Accc Dept.===ip address 192.168.102.254 255.255.255.0endwri
- Nếu kết nối nhiều switch Access/Layer2 nhân bản
conf tinterface Ethernet0/2description ===Linked to Access Switch===switchport trunk encapsulation dot1qswitchport mode trunkswitchport trunk allowed vlan allendwri
conf t
hostname Acc-01
ip domain name khanhvc.lab
no ip domain-lookup
banner motd #===Acc-01 HR Dept.===#
username admin privilege 15 password itadmin
service password-encryption
line con 0
logging synchronous
login local
exit
line vty 0 4
login local
transport input all
crypto key generate rsa general-keys modulus 1024
ip ssh version 2
!
interface Vlan1
no shutdown
description ===MGMT===
ip address 192.168.1.11 255.255.255.0
exit
!
vlan 101
interface Vlan101
no shutdown
description ===HR Dept.===
exit
!
interface Ethernet0/0
description ===Linked to Core Switch===
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
exit
!
interface Ethernet0/1
description ===Linked to PC===
switchport mode access
switchport access vlan 101
no shutdown
exit
!
end
wri
- Nếu tạo thêm vlan thì chúng ta nhân bản vlan lên ví dụ vlan 102 (vì là layer 2 nên khi tao vlan chúng ta KHÔNG đặt ip trên interface vlan này)
conf tvlan 102interface Vlan102description ===Accc Dept.===endwri
- Nếu có nhiều thiết bị đầu cuối muốn gán vào vlan 101 chúng ta nhân bản lên
conf tinterface Ethernet0/2description ===Linked to PC===switchport mode accessswitchport access vlan 101no shutdownendwri
- HOẶC chúng ta cũng có thể cấu hình theo range interface vào vlan 101 cũng được ví dụ từ port 3-9 (tùy từng dòng sản phẩm mà phần range có thể là khác nhau tí tí)
conf tinterface range Ethernet0/3-9description ===Linked to PC===switchport mode accessswitchport access vlan 101no shutdownendwri
conf t
ip dhcp excluded-address 192.168.101.254
ip dhcp excluded-address 192.168.101.1 192.168.101.50
!
ip dhcp pool vlan_101
network 192.168.101.0 255.255.255.0
dns-server 8.8.8.8
default-router 192.168.101.254
lease 0 0 10
end
wri
- Nếu muốn nhân bản cho vlan khác thì copy và chỉnh lại chổ vàng vàng (nếu muốn Core làm DHCP server cho vlan đó)
conf tip dhcp excluded-address 192.168.102.254ip dhcp excluded-address 192.168.102.1 192.168.102.50!ip dhcp pool vlan_102network 192.168.102.0 255.255.255.0dns-server 8.8.8.8default-router 192.168.102.254lease 0 0 10endwri
conf t
interface Vlan101
ip helper-address 192.168.100.100
end
wri
- Nhân bản cho vlan khác: Ví dụ như vlan 102 muốn DHCP server có địa chỉ IP 192.168.100.100 cấp DHCP client cho vlan này
conf tinterface Vlan102ip helper-address 192.168.100.100endwri
conf t
interface Ethernet1/3
switchport access vlan 103
switchport voice vlan 99
end
wri
- 1. VTP Server
- 2. VTP Client
- 3. VTP Transparent
conf t
vtp domain khanhvc.lab
vtp password vtpadmin
vtp version 2
vtp mode server
vtp pruning
end
wri
conf t
vtp domain khanhvc.lab
vtp password vtpadmin
vtp version 2
vtp mode client
end
wri
conf t
vtp domain khanhvc.lab
vtp password vtpadmin
vtp version 2
vtp mode transparent
end
wri
conf t
interface Ethernet0/1
description ===Connect to LAN/CoreSwitch===
ip address 192.168.200.1 255.255.255.248
no shut
ip nat inside
exit
interface Ethernet0/2
description ===Connect to ISP-Router===
ip address 125.234.102.243 255.255.255.248
no shut
ip nat outside
exit
!
ip nat inside source list 1 interface Ethernet0/2 overload
!
access-list 1 permit any
!
end
wri
STT | Nhóm | Commands | Giải Thích |
---|---|---|---|
1 | show running-config | Hiển thị cấu hình hiện tại đang chạy | |
2 | show vlan | Hiển thị các vlan đang tồn tại trên switch | |
3 | Interface | show ip interface brief | Hiển thị trạng thái up/down và thông tin IP của các interface |
show interface | Hiển thị trạng thái up/down, trạng thái giao thức trên interface, MTU, Lỗi,... | ||
show interface trunk | Hiển thị thông tin về port trunk trên switch | ||
show run interface Et0/1 | Hiển thị cấu hình hiện tại của interface Et0/1 | ||
4 | Routing | show ip route | Hiển thị thông tin bảng định tuyến của thiết bị |
5 | show version | Hiển thị thông tin register thiết bị, firmware, tên IOS, flash, RAM, ... | |
6 | VLAN | show vlan summary | Hiển thị trên switch hiện tại có tất cả bao nhiêu vlan |
show vlan brief | Hiển thị thông tin vlan và các interface nào gắng vào vlan nào | ||
7 | DHCP | show ip dhcp binding | Hiển thị tất cả các IP đã được cấp cho DHCP client |
show ip dhcp conflict | Hiển thị các IP đã cấp phát nhưng bị trùng | ||
show ip dhcp server statistics | Hiển thị thông tin chi tiết về dhcp server | ||
show ip dhcp pool | Hiển thị thông tin chi tiết và các pool dhcp | ||
show run | section ip dhcp | Hiển thị tất cả các cấu hình có liên quan đến cấu hình dhcp server | ||
8 | VTP | show vtp status | Hiển thị thông tin cấu hình vtp |
show vtp password | Hiển thị thông tin password của vtp | ||
9 | NAT Overload | show ip nat translation | Kiểm tra bảng NAT |
clear ip nat statistics | Xóa thông tin bảng NAT | ||
show ip nat statistics | Hiển thị thông tin bộ đếm và các thông tin liên quan đến NAT | ||
9 | Access-List | show access-lists | Hiển thị thông tin Access-List |